Cannot select country for Brave Rewards - no options in dropdown

Briefly describe your issue:
I cannot select a country for Brave Rewards because the dropdown is not populated. I was previously connected in this profile. If I create a new profile, the dropdown is populated.
What Operating System and Brave version are you using (Menu --> About Brave)?
OS: macOS 13.0 (22A380)
Browser: Version 1.47.55 Chromium: 107.0.5304.91 (Official Build) nightly (x86_64)
Is your browser wallet currently verified? (yes/no)
It is displaying Unverified on the Rewards page. If I click that button, nothing happens.
What date did you verify your wallet?
Years ago
Have you been able to successfully receive payments in the past?
Are you using a VPN? (yes/no)
Are you eligible for Brave Rewards (see here for list of supported regions)?
Are you on the list of supported regions when verifying Brave Rewards with a custodial partner (see here for list of supported regions)?
Does your device pass the SafteyNet check (Android only)?
Have you manually turned off Auto-contribute on all of your devices linked to a custodial partner?


Probably a bug. It should be fixed in the coming release I guess. @SaltyBanana @Evan123 please look into this.

1 Like

Just reporting that I’ve got the same issue. Was previously working fine, now I can’t even see my rewards.

OS: Win10 21H2 19044.2251
Version 1.46.134
Chromium 108.0.5359.94
Wallet is unverified


@MegaByte and @TiredEyes I just had someone from Brave talk on it. They want us to ask everyone the following:

Can you go into brave://settings > Page zoom, and tell me what your Page zoom is at? Can you try at a low page zoom, such as 100% (or lower) and see if that fixes it?

Actually, shoot, MegaByte, been a while and guess yours was lost. You still having this issue?

Page zoom is/was 100%.

In trying to resolve this, I ended up following these directions: No Ads On Desktop Windows After Month Of Install
After following the instructions, it actually allowed me to choose a country, but when trying to reconnect to my external account, it says that the profile is flagged and I cannot continue. Very upsetting.

Can you advise specifically what you changed? I know I was looking for specific words but the text in current flags are different. Such as they said Enable pop up ads but that doesn’t exist. There is Enable Brave Ads custom push notifications but I’d rather not just assume you equated those as the same.

Then for Allow Brave Ads to fallback from native to custom push notifications, that’s still a thing. So if you’re saying you enabled that, might be it.

Just want to see specifically the changes and then suggest for others to try, to see if it works.

I toggled both of those that you mentioned at the same time, so I didn’t see if one or the other was effective.

1 Like

Can you open a ticket here regarding your flagging? The support team will be able to review it and remove it if possible.

My page zoom was set to 90%, and I then changed it to 100%, but still the same error

I also tried the solution that @MegaByte posted, first enabling
“Enable Brave Ads custom push notifications”
and then relaunching - didn’t change anything

I then enabled “Allow Brave Ads to fallback from native to custom push notifications”
and relaunched, still nothing

Deactivated both and then set them at the same time before relaunching, but I still haven’t been able to get into the country dropdown.

@MegaByte and @TiredEyes teams are still working on it. In one of the discussions we had, I realized hadn’t asked anyone to try in Beta or Nightly. If either of you would mind giving it a shot, will be a bit helpful for them to see if perhaps it’s a version specific issue.

Yes, as Saoiray says, if you are having this issue, can you please try on Brave Nightly (latest version) and see if the issue remains? You can download the latest Nightly here: Thanks all.

So this worked - Once I’d got past the initial setup Nightly asked me to set up rewards again and then had the dropdown available with all countries.

However, I also ran into a different issue- it asked if I wanted to import bookmarks and settings, but there wasn’t a Brave option available, only an ‘Unidentified Chromium Browser’.
I tried to import from that but clicking the button did nothing, so I skipped it. Now the regular ‘Import bookmarks and settings’ doesn’t have an option to import from the regular Brave installation:

I’m less bothered about rewards than moving my setup manually over to the Nightly installation but if you want me to try anything else just for testing let me know.

@TiredEyes Well, it wasn’t so much about moving over to Nightly permanently unless that’s what you want to do. It was more about just testing to see if it works. Hearing it does means that likely is just something version specific causing this problem and is otherwise resolved. I know @chriscat and the rest of the team is looking into it. You’re the second one to say that it resolves in Nightly.

I’d just like to hear if that means step closer in rolling out a fix, if it primarily means having to wait until Nightly rolls out, or if it means something else entirely, lol.

Btw, in terms of settings, you’d probably be best just to Sync if you want to keep using it. Set up a chain and then put it in on the Nightly version. Otherwise you’ll just Export from brave://bookmarks/ on other version and then Import in the same spot on Nightly.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.