Cannot log in to Google account using OTP

Description of the issue:
Error received when attempting to authenticate login. The browser occasionally crashes after failing to verify OTP. Because I require an OTP using a device such as Yubikey I am unable to use my Google account on Brave and I am not willing to downgrade my security protocols.

Exact URL of the website in question:

Did the issue present with default Shields settings? (yes/no)
Yes

Does the site function as expected when Shields are turned off?
No

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
No

Does the site work as expected when using Chrome?
Yes

Brave version (check About Brave):
1.32.3

Apparently this has been a known issue since version 0.59.35 in 2019 (Yubikey fails after update)

Please fix this asap. This is a vital tool for maintaining privacy and security

I have a ubikey and OTP enabled (and a number of Brave staffers using Ubikeys) I haven’t seen issues here… However, I’ll retest to be sure.

Interesting. I’ve tried logging in from Brave using iPhone android and windows and they have all failed. Works fine in chrome on all three.

Just to clarify, on android there is an option issue https://github.com/brave/brave-browser/issues/7756

Desktop yubikey works without issue.

Gotcha. Well my desktop(s) and iPhone/ipad(s) aren’t getting the memo. Still no joy. Is there any way to capture an error log that I can submit for review?

My testing: https://gif.fanboy.co.nz/gif/google-auth.gif

  1. Try from a clean Brave profile, test in Brave Beta
  2. Screen recording of it failing in Brave beta and output from the dev console.

I will get on that right away. Would you mind telling me how you blurred your video out like that?

using screen2gif software. alternatively message me a unlisted youtube capture

Thank you! I actually got everything to work on my Windows account now by signing completely out of my account (it had only let me sign in partially with my password but when I tried entering my OTP it failed). Problems I was having on another website turned out to be a password issue.

I’m still stuck with my iPhone. I’m gonna do some more troubleshooting and reset some things and see if I can get it figured out and follow up later. I’m so glad that it looks like this issue is a non-issue. I can now completely avoid using Chrome.

Asking other staffers regarding yubikey and iOS, I couldn’t get past the login process on gmail with yubikey/NFC on my iphone

Oh wow so something really weird is happening. Clearing all cache/cookie/app data didn’t work on my iPhone so I went to my iPad and tried the same thing but went a little further and went to the account on my iPhone settings and signed out there. Now, on my iPad I can’t even sign into Chrome (or Safari) with my yubikey. So now I am locked out of my Google Drive and a bunch of other things.

I enabled the VPN for my account about a day after first using Brave and weird things have been happening on my computer and phone/tablets since I activated the VPN. I don’t know if that has anything to do with? All I know is since I activated it, sometimes things take ages to load or apps decide to connect to the internet intermittently. It doesn’t matter if I have the VPN on or off and it does the same thing including in Chrome. Any thoughts on why this may be happening?