Cannot import passwords from Chrome or CSV

**Description of the issue: I uninstalled Brave 64 bit on Win 10 and then reinstalled it. After reinstalling it, my stored passwords are empty. When I try to import them from Chrome I get the blue checkmark pop up indicating the import was successful, but the password vault is still empty. Same thing with CSV. On the same computer, running 64 bit Beta version of Brave, I can import and export passwords without issue.

**How can this issue be reproduced?

  1. By attempting to import passwords from Chrome, CSV exported from Chrome, or a CSV exported from beta version of Brave.

**Expected result: Passwords would be added to vault and available when browsing.

**Brave Version( check About Brave): v 1.0.0

**Additional Information: Beta version v 0.72.124

@Esus,
I just tested on Windows and I was able to import using the built-in import feature as well as direct .CSV import using Brave 1.0 on Windows 10 OS.
Are you using the Admin account on your Windows system?

@Mattches Yes, I am an admin on the machine.

What’s odd is my beta version works fine.

Yes that is very strange to say the least. Are you okay with using the Beta build for the time being? I can go ahead and reach out to the devs to see if they may know what’s going on in the meantime.

Yes. This has actually been going on for a couple of weeks and I’m just now getting around to trying to fix it. Beta is fine for the time being.

I just tried uninstalling and doing a fresh install and then importing again - same results, no passwords.

Please let me know if the devs can help. Thanks!

1 Like

@Esus,
Out of curiosity, when you uninstalled, did you elect to remove all data as well? Also, when you reinstalled and launched, did you attempt to use the Import bookmarks and settings feature first – that is, before attempting to import the .csv directly?

I did not elect to remove all data. I was hoping to retain my browsing history and other data since I had been using Brave for the better part of half a year before I had issues that prompted me to reinstall. If I wipe the data, reinstall, then import from Chrome I’ll half a half year gap.

When I reinstalled again on Friday I used the import bookmarks and settings first (slecting first chrome user) which didn’t work. After that I tried the import from csv directly.

@Esus,
Apologies for the late response – I’m just returning from some time off.
Can you confirm whether or not you’re still experiencing this issue?

I hadn’t looked at it since we last spoke. I just fired it up and apparently it’s working again. All of my history and stored passwords are working as expected. Odd. Oh well!

Any word on when Brave might add password storage to the Sync Chain? Is that even on the dev path?

Thanks again.

1 Like

@Esus,
Man that is strange. I’m glad it fixed itself for you but I do want to know what the initial cause was still :stuck_out_tongue:

Yep! We’ll be putting a lot of time and work on new Sync functionality and efficiency very soon. I believe we have some issues you can follow here: