Importing Chrome content not quite right (passwords missing)

windows
#1

Description of the issue:

I have just migrated from Chrome to Brave and used the “import settings” to import my Chrome stuff. Favourites and other things have imported, but saved passwords did not which is killerrrrrrrrrrrrrrrrrr!

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Download and install Brave
  2. Menu
  3. Settings
  4. Import
  5. Select Chrome profile
  6. Make sure that “Passwords” is enabled for import

Actual Result (gifs and screenshots are welcome!):

Check “Saved Passwords” and see nothing is in there :sob:

Expected result:

Chrome saved passwords should also import, not just favourites.

Reproduces how often:

Every time I retry importing!

Brave Version(See the About Brave page in the main menu):

0.60.47

Reproducible on current live release (yes/no):

Yes

Additional Information:

Built in Importer doesn't import data correctly
#2

@willstocks_tech thanks for reporting!

I’ve just checked the issue on Windows 7 x64, Brave 0.60.47 and the passwords were imported without problems.

Have you used Brave before trying to import the passwords? Could be that you tried to login to the same page before importing?

Could you provide your OS?

1 Like
#3

Hey @btlechowski,

No, I have never used Brave before - I’m a first timer! I followed the instructions for importing from another browser (in this case, Chrome) to the letter! The import was the first thing I did - I had not browsed to any other pages before trying to import.

OS: Windows 10 Enterprise x64
OS Version: 1703
OS Build: 15063.1631

Importing passwords from: Chrome 72.0.3626.121 (Official Build) (64-bit)

Let me know if you need any other info - all bookmarks came through fine, it looks like it’s just the passwords that didn’t :frowning_face:

Thanks,

Will

1 Like
#4

Same problem here but in Windows 7 Home Premium 32 bits…

#5

Same problem here in OS X High Sierra

#6

For anyone experiencing this issue - can you try the importer again and ensure that the following conditions are true:

  1. You have no additional browser Windows open - specifically Chrome Windows. If so, kill those processes.
  2. Whichever data the importer did not grab (in this case, passwords), try selecting only the passwords checkbox in the importer dialog. We have previous issues with the importer wherein the process would hit a point of failure when fetching some data and would subsequently halt and exit the process after that point (even though it says “successful”).

So any other data that followed the point of failure would not be read or fetched. Selecting one data at a time is a good way to resolve the issue (if that is in fact the case) as well as diagnose.

Let me know if this works for anyone.

2 Likes
#7

Hi @Mattches

I just tried this - on my Windows 10 machine (where I’ve had Brave installed for a couple of days now) it did not work at all. I tried:

  1. Importing individual tickboxes
  2. Importing all tickboxes
  3. Importing just passwords

No change in the passwords at all. I even tried with Brave being the ONLY application open on the machine… no success :frowning: despite it giving me the big blue tick - I have all my bookmarks though!

I just did a fresh install of Brave on my MacOS Mojave (10.14.3) machine (never had Brave on it before), closed all browsers first, then launched Brave and did the import and it worked perfectly (it’s probably worth having an instruction pop-up first to say “close all browsers before importing”?)!

Any ideas what I can do to get the import to now work on my Windows 10 machine (I don’t sync between the two - one’s a personal machine, one’s a work machine).

1 Like
#8

@willstocks_tech,
Thank you fro the additional information and for digging into the issue and testing yourself. Good to know it works on macOS.

I’ve reached out to a few team members for additional input as this seems like a regression in the importer feature and that should be taken care of asap. Appreciate your patience as we look into this, I’ll return when I have more information or an issue to direct you to.

1 Like
#9

Morning @Mattches,

Have you heard anything further in relation to this one?

#10

We’ve opened an issue in Github:

What would really be helpful

If users – even if you’ve already reported this issue before – could reply here with some details about what did (or did not) get imported when they tried using the importer:

closed #11

Closed in favor of “master” issue below.
Even if you’ve already reported this issue before – reply here with some details about what did (or did not) get imported when they tried using the importer if you’d like to help us get this issue resolved: