Can only choose Uphold as wallet, not Gemini

Briefly describe your issue:
When trying to add a verified wallet the only option I get presented with is Uphold. It works perfectly fine on my laptop but on my main desktop the option to choose Gemini doesn’t appear.

What Operating System and Brave version are you using (Menu --> About Brave)?

  • Windows 11 Home, Version 21H2 OS build 22000.613
  • Version 1.38.115 Chromium: 101.0.4951.64 (Official Build) (64-bit)

Is your browser wallet currently verified? (yes/no)

Have you been able to successfully receive payments in the past?

Are you using a VPN? (yes/no)
I have in the past.

Are you in a supported region (see here for list of supported regions)?
Yes, Belgium.

Are you still experiencing this issue?

Yes, still a problem

So strange. Belgium is in the list of Brave and Gemini supported countries so that shouldn’t be the problem.

If you haven’t already…

  1. Make sure your OS & Brave are updated to the latest version.
  2. You could try creating a new profile and see if the option is available. You can then delete the new profile. Do not connect or it will count towards your 4 slot linking limit.

@Mattches Tagging support staff to see if they can take a look.

Didn’t solve the problem sadly.

OK, support staff usually don’t pop in this late in the day and the weekend is starting here in the USA. Support staff normally do not work weekends. So, you are probably not going to get a response from a moderator on this for now.

Just submit a request form to have support take a look. The link is below. Your request will be put in a queue and support works on them in the order received. Sorry your issue has been open so long without support staff input. Here’s hoping the form submittal route works and the queue is short! Good luck and take care. :smiley:

Sorry for the late reply, I’ve had a few days off.

First can you please update your browser to the latest release? Then, I’m curious if you try creating a new temp. browser profile, whether or not you still see only Uphold when viewing that menu in the new profile?

We’ve filed the issue here: Our developers and team will be taking a look, as we consider this a bug.


Updated Brave and made a new temp but still no luck.

If you go to brave://flags and search for Enable Gemini for Brave Rewards and set the value to Enabled (make sure you relaunch after changing the value) does the option appear?


It actually worked. No idea how the value was set to Disabled. Thanks a lot!


This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.