Camera issues w/ Google Meet

I use Google Meet for all my video conferencing with my company. For some reason, the webcam I use does not work on Google Meet, but it works with all other conferencing platforms (webEx, Zoom) as well as my own Macbook camera app. The only way I’ve been able to get the camera to work on Google Meet is to start a conference on Zoom, then open Google Meet, then close Zoom. I noticed that it works fine for Google Meet calls on the Chrome browser. How do I fix this issue? I am on a 2021 Macbook Pro with the M1 Pro chip.

@peter13,
Thank you for reaching out.
First, check that you have the following option enabled (“on”) in brave://settings/extensions:

Then, visit meet.google.com and confirm that the site has been granted permission to use your camera — click on the “lock” icon in the address bar, then Site settings and confirm that camera permission is set to Allow.

Hi @Mattches, thanks for the reply. I just checked, the setting has been set to “on” on the extensions page for Hangouts and I can confirm that the site has been granted permission to use the camera as well.

Any other ideas for ways to fix this?

Thanks,

Peter

I would try resetting permissions for the site, refreshing, then granting access again to see if this shakes some thing lose.

You can do this from the same menu:

  1. Visit meet.google.com
  2. Click the “lock icon” then Site settings
  3. Click Reset permissions

Refresh the page, grant access to your mic and camera and then test to see if you get the same results.

@Mattches I believe I found the issue. The camera seems to work fine on the lowest resolution but not on the higher resolution options. Not a huge difference between the resolution options so just going to use the lowest for now. Thanks for your help!

@peter13,
Thank you for the update. Can you tell me whether or not you changed the res in Google meet directly or if it was changed on your system?

@Mattches I had to change it on Google Meet. The system camera apps seem to work fine.

1 Like

Thank you again for confirming. Marking this thread as solved.