Bug? Unable to Download/Save Anything. Browser Freezes

This started yesterday. I haven’t changed anything. Using a Mac. Both Mac and Brave are up to date.

Yesterday, I tried to download a file from an email. The save box comes up and gives me the option to save or cancel, but at that point everything is frozen. I can move my mouse and everything, but can’t press any buttons, can’t close the save window, can’t switch between tabs. If I look in the toolbar at the bottom, there’s a blue wheel on the Brave icon, it fills completely in blue, but then nothing happens. My only option is to force quit Brave, then I get a notification that a download is in process, am I sure I want to quit and cancel the download.

Tried to download a file from a website today, same thing. Brave becomes completely unusable when the save window pops up.

Please help!! There are files I need to download for work and I don’t want to have to go back to another browser.

I believe I’m facing something similar, my browser is freezing when I’m trying to browse.

I suggest that you create a fresh user profile that we will use for testing purposes to determine whether the issue is related to your current user profile.

I’m not really sure but: when it happens, try command-click control-click the Brave icon in the Dock and choose “Show All Windows”, I suspect some dialog box opens up underneath another window.

“command-click” is wrong. I meant “control-click” (or right click if the mouse provides it).
“command-click” should open Finder and select the application folder.

I created a test profile, then just randomly selected an image on Google to save, still freezes as soon as the save window pops up.

What’s frustrating is I can’t even save my bookmarks, so I don’t really have the option to delete Brave and start fresh.

Gave this a try. There’s nothing else open other than the Brave browser window I’m in.


Thank you for checking. Although I don’t understand the issue as a typical crash, it might be worth checking for any crash ID’s over brave://crashes.

Have you enabled any flags via brave://flags recently? You could check brave://flags for any changes - if a flag has been changed, it will appear with a blue dot next to its name, also should be displayed at the top of the page.

Just checked crashes. I had that disabled, so I enabled it and attempted to save things a few times. Reloaded Brave, but it says there are 0 crashes.

I don’t even know what flags are, so I didn’t intentionally change anything there. I tried resetting all just to be safe, then tried saving things again. Still freezing.

All right. Could you check whether disabling Hardware Acceleration via brave://settings/system has any impact?

Gave it a try. Still freezes if I try to save.

I’m curious – if you were to try going to Settings --> Additional --> Downloads and toggle the Ask where to download each file before saving option to “Off”, then try to save a file do you still get the same behavior?

Sorry for asking the obvious, but are there any download managers involved?

Yes, still same issue. Even with the option off, I’m still getting the save window popping up.

I’m not sure what you mean by download managers. Like extensions? All I’m doing for trial testing right now is going to the google main page and right clicking the image on the page, clicking save image as, then I get the save window and it freezes.

I can’t even control-click the image on google.com, the game or whatever it is starts up instead.
Images from google image search results I can download.
macos here too – old one though, el capitan.

Yes, with “download managers” I meant extensions, or external programs that can take over a download from the browser.
I recall having had a similar trouble with Firefox and one of those time ago.
But if you don’t use any, that’s another possibility ruled out.

I had same problem, whenever I start a download, a bar appears on bottom showing the download and as soon as it appears, my Brave browser freezes…
Here is what I did:
I pressed command-option-esc and then force quit box appears, where I saw one app (preview) which was running but not showing on dock, so I force quit it and made sure nothing else is running in background. Then I force quit Brave and launched terminal. I used command sudo purge and entered password so computer could free up and boost RAM on my computer and then I restarted Mac.
After this 3 minute process, now that bug is fixed and I am currently downloading while writing this… :v: :fist:

“Preview” trying to open the file, that’s interesting.
It rhymes with the fact that, judging by the description of the issue, the browser is technically neither crashing nor hanging, yet is unable to respond to user input – not a significant difference from a user experience perspective, but a different kind of problem technically.

By the way, does anyone know where “mime types” and file type associations are in Brave?
I did not find them anywhere.

Ok, so interestingly enough, Preview was open, but not appearing in the toolbar earlier this morning. I force quit it a few hours ago (I quit everything just to start with a blank slate in hopes that that would work).

I’d like to try this terminal thing, but I’m afraid that’s way out of my knowledge. Can you explain (or direct me to an explanation of) how to do that? I’m willing to try absolutely anything to get this resolved.

Applications → Terminal Screen Shot 2021-08-26 at 21.38.53

Type man purge then press enter to see what it does – then q to quit the reader.
Type sudo purge then press enter, then when prompted type your computer user password followed by enter to proceed.
It should flush the disk cache from memory, releasing some RAM for other processes – in case it’s freezing because out of memory.
P.S. careful what you type in a terminal window, it’s easy to unintentionally wreck something there.

But I think the problem here is that “preview” shouldn’t open in the first place, and I have no idea why it does.


Success!! Thank you so much!! I’ll have to write this down and remember it if this happens again. Such an easy fix!! Thanks again!

I do notice that Preview often stays open even after it’s been quit, since I first bought this laptop. Such a weird glitch.

Thanks to everyone involved in helping me resolve this issue.

Answering myself: apparently (all?) Chromium browsers, unlike Firefox, do not have an internal association list but rely on the operating system one – from this SO thread:

@TheOtherNiki Yeah, I understand being afraid of that terminal application if one don’t know much about it. I was afraid too, when this was new to me.
All you need to do is, first of all, quit all applications. Make sure to check via force quit window whether any hidden app isn’t running in background. Now, launch terminal (either via applications, launchpad, or spotlight search), and then write “sudo purge”, don’t use double inverted comma, and there is a space between sudo and purge. After that hit enter, terminal will request your user password. Enter your password and hit enter.
That’s all.
Now, as soon as you hit enter, your mac will freeze, for like 1 or 2 seconds only. And, then everything will work fine. Now you can quit terminal and for best results, you may restart your mac.
The stuff this command do is to free up your unused memory. I don’t think it do much, because unused memory is the memory which is not used. But, I do find some pace in my mac after running this command. So I use to run this command about once in month or so. This command simply free up unused RAM and free up the stress upon RAM for a temporary duration. I don’t do this much often, only when my mac is running slow and I need to do video editing, or gaming (I am happily gaming on mac :face_with_hand_over_mouth: )
You may read some articles like these ones
CNET - Tech - The necessity of regular use of the ‘purge’ command in OS X
on this site