[Bug] Search/address bar on android not working

Description of the issue:
I accidentally found a bug when surfing on my Brave Android. I’m not sure how to title this bug but this is what I encountered.

I was surfing for “GPS” and found gps.gov. I tapped it and loaded the site. On the same page/site/tab, I typed once again for “GPS”. But instead of being taken to a new search result (I use Brave Search), it loaded the same page (gps.gov). This went on infinitely.

I tried reproducing on another site archive.org, and typed on the search bar for “archive” and got the normal result instead of the previous problem.

Steps to Reproduce (add as many as necessary):

  1. Launch Brave Android
  2. Type gps.gov to load the site
  3. Type “gps” on the same search bar as the site

Actual Result:
The site is reloaded

Expected Result:
A new search result should appear

Reproduces how often:

Brave Version:
Brave release - v1.50.121

Reproducible on current live release:
Is it a nightly built? I haven’t tried

Additional information:
I’m using Samsung Galaxy S10+ (SM-G975F/DS), Android 12 (OneUI 4.1)
Last updated my Brave through Aurora Store.

This is a temporary account just to report this bug.

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.