Google Search Don't work

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.


Description of the issue:
Google Search Don’t work on Brave Browser Nightly Android

How can this issue be reproduced?

  1. Open Google.com
  2. Make a search of anything
  3. See the error

Expected result:
See the results of the search

Brave Version( check About Brave):
1.41.57 Chromium: 103.0.5060.42 (Build oficial) canary (32 bits)

Mobile Device details
Samsung A70
Android 11

Additional Information:


The FIRST screenshot is good: a valid Google Search result for search criteria ‘cloudflare’ . . . but:

Translation for the SECOND screenshot - thanks to ‘deepl.com

An error occurred when the web page was displayed.

If the message appears frequently, try these suggestions (link undetermined because of screenshot).

Reload again

From the 1st screenshot it automatically passes to the 2nd screenshot in milliseconds

I have the same results.

The successful search page will show briefly, immediately followed by an error page, regardless of what phrase is searched

This is true if the search/address bar is used AND if I navigate to google.com and then search for something

I’m not seeing this error when testing on my end (Nightly using Galaxy S22) — Google searches seem work as intended. Can anyone here encountering this check and see:

  • If the issue occurs when using a Private browsing window?
  • If the issue occurs if you turn Shields down for Google.com?
  • If the issue occurs if you’re not signed into Google at the time you perform the search (test this in a standard window)?

Thank you

Checked Nightly on my s10e running Android 12. No issues. Also tried a private window. Again, no issues. Tested with shields up and down.

Hello @Mattches

Yes, the issue occurs in a Private browsing window. The cell phone does not allow me to take a screenshot in a private window.

Turning Off Shields - Same situation


Sign-Out Google Account - Same Situation


It is very strange because it only happens in the Nightly version for Android

Nightly is the most likely build to have errors and issues so things like this are expected. Can you try clearing your cache and site data and test to see if this resolves the issue?

I did this



Same situation

Well, it’s not something very necessary

It is only to report this issue

Thanks

Thank you — I will let the team know about this issue and take a look if necessary.

Can you try disabling Vulkan, brave://flags/#enable-vulkan then restarting the browser @cmam @Herrvader @ccraighead

it does’nt work

I have the same issue. I had to change Google as the search engine to another to make it work.
Which means it’s something between google and brave nightly app

Does Brave Beta work? or in Brave release (if you Clear browsing data, then exit Brave/restart)

No issues on my end. Was just posting that mine was working with the device and android version I was using. In case it was helpful I suppose…

The issue only happens in Nightly for Android.

Release and Beta versions (Android) work fine.
And Nightly/Beta/Release/Dev for windows windows 11 work fine too.

Yes. I already tried to clear browser data and restart the phone.

Same situation

1 Like

I can confirm this. I made a post about this in the noon. Having the same issue. Google search just crashes. .50 didnt had this problem. .62 does.

1 Like

Which phone and android version are you using? @cmam

Also having the same issue with Brave Nightly. Have tried reinstalling the app, clearing cache, cookies, etc.

Version 1.41.62, Chromium 103.0.5060.42
Samsung Galaxy S21+

Started yesterday.

@cmam