Brave quits when trying to allow microphone

Description of the issue: Hello, Every time I click allow microphone any page on my brave browser, the application crashes/quits. Ive gone into the settings and after every time it crashes, the browser automatically blocks the site from using the microphone. Ive tried going into the voice settings of these websites (one of them being discord) to see if it’s a problem with the site, but i cant even do anything without clicking “allow access”. It just quits every time i try to even allow it to access the mic.

Expected result: I would like to be able to use my microphone lol

Brave Version: 1.24.82

Hey @sapphic_nobody,

Just tried it on the web Discord, and it seems to work just fine on my end. Just to be a bit clearer, can you answer some questions for me?

  1. I always suggest disabling hardware acceleration, as that does tend to cause some issues. Can you turn that off and see what happens?

  2. Are you using the built-in mic, or an external one?

  3. What extensions are you using? They’ll sometimes cause some issues as well.

  4. Does this issue also happen on Chrome?

1 Like


  1. i just tried disabling hardware acceleration and it didn’t work

  2. i’m using the built in mic

  3. the only extension i’m using is Hoxx VPN proxy

  4. this issue doesn’t happen with chrome


Try going to → and download a new Brave installer. After it finishes, Force Quit Brave.
Re-run the installer you just downloaded, but do not uninstall Brave.
If you get a prompt saying ” Brave already exists”, select replace.
After it reinstalls, test out your microphone issue again. Hopefully this’ll do the trick.

Hey sorry for the late response,
I got the installer, force quit brave, and then re-downloaded it, but it didn’t give me the prompt to replace the already existing one. It just gave me another browser application. The problem remained the same when tested.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.