Broken website in Brave for iOS / iPadOS - techcrunch.com - default settings


Description of the issue: techcrunch.com is broken

Exact URL of the website in question: https://techcrunch.com

Did the issue present with default Shields settings? (yes/no): yes

Does the site function as expected when Shields are turned off? (yes/no): yes

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no): no

Does the site work as expected when using Chrome? (yes/no): yes

Brave version (check About Brave): iOS / iPadOS latest version

I browsed the site, looks fine on iOS. What is the issue exactly?

I think the problem happens when you browse on an iPad. When the display is big and you request the desktop version of the site, the top screen and left and right bar are gone. if you look at the second screenshot, you can see the website begins only where there is “Education” headline, but in the first screenshot you can see that there is more content that is not being displayed

I dont know if the screenhots I uploaded are clearly separated but they are 2 different screenshot, not one. The first show the website working properly with protection disabled, the second show what happens when protection is enabled. Content is missing

could be the site itself, showing desktop vs mobile experience being different? I only have a iPhone to test btw

I dont think its the webite causing it. Does requesting the deesktp version in your iphone replicate the issue on your end?

On android, If I switch to Desktop I’ll get some additional paragraphs. Switching to Mobile version will cut this down to just headings.


Hi. Can it be solved with new rules?

Not with any rules, the desktop/mobile mode is supplied by the site