Braze not displaying / loading / caching map tiles

Description of the issue:
I look at map side by side on Braze and Chrome - chrome works perfectly, but Braze isn’t showing map tiles. I poked at it a bit, it is GETTING the map tiles I believe, or a quality VERSION of them, it’s not DISPLAYING them. It’s actually fairly unuseable at this point, since everything else is working in, I just can’t see where someone is because the map is missing

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Log into - I suspect this might be reproduced maybe with the SOURCE map they use, but I didn’t drill that far, I couldn’t really find the direct map login / link - but maybe you could reproduce and get out of the way as not-on-point. Log in on both browsers. Create a scratch account if needed.

  2. Go to the same spot on the map in both browsers - I picked Freeport, Texas, but right around my house is the exact same thing. Zoom in to exact same level - distances are static levels - 5km out is when braze failed.

Actual Result (gifs and screenshots are welcome!):

STEP 1: Look at this photo

Brave on left, Chrome on right - I’ve given brave lots of time to load that page - zooming in gets some but sporadic map tile square data that appears briefly, then disappears, zooming out gives the full map. But all that grey is where it refuses to draw in the map. Like I said, the map for 1 second LOOKED perfect - but then the grey appeared, removed the “downloaded” tiles… and it’s just grey.

STEP 2: I zoomed out and then back in again and got this really fast

Now this looks like - oh, problem solved right? But what it really is if you look closely, the tiles where the grey was are a pixelated version that isn’t finished yet - Chrome replaces those sections as its fine tunes them - or downloads them, or I don’t know what.

STEP 3: I carefully marked the area on the above screen shot - this is the area that is perfect inside the box, outside the box is still pixelated, not drawn in fine-detail yet

=> Couldn’t attach image example , 4 links max I was just told - but if you look closely at the above, the quick zoom version has pixelated version outside where the grey is

Expected result:
It re-draws the "pixelated non-finished map segments properly.

What is happening? It depends how map draw in / zooming works - you see it all the time with squares updating on all maps - google, this one, etc.

  • If the web server sends perfect final images, and Braze is down-grading them to show them quicker, then re-rendering them to show better, maybe thats it - I kind of doubt this, this isnt how streaming web site date really works.

  • If the web server sends very fast low quality images, then re-send higher quality ones - either Brave isn’t GETTING the higher quality, or isn’t showing them, etc. I think this might be more likely.

But I know it’s not my connection, or even probably their web server, since I’m using the same exact machine with diff browsers.

Reproduces how often:
Repeatedly - over and over

Operating System and Brave Version(See the About Brave page in the main menu):
Machine details:

  • OS: MacOS Mojave 10.14.6 (18G87)
  • Brave version: Version 1.2.42 Chromium: 79.0.3945.117 (Official Build) (64-bit)
  • this does not happen on the very latest Chrome 79.0.3945.117 (64-bit)
  • this does not happen on the very latest Firefox 72.0.1 (64-bit)

Additional Information:
If it helps, if someone can tell me how to look in the image / disk cache for Chromium / Braze I will go clean it out, reproduce with limited steps, and then see if I can find the diff versions of the map segments - I would assume that the images are cached, I just dont know where, if they are on disk in plain site, or how to see them.

here is another image - this one looks like more of freeport is filed in, still the 5km range - so same image tiles?

So this means that what? More images came in? Is it taking 15-20 min to fill in? A refresh, even a log out and log back in doesn’t fix it. The tiles are coming in, but very slowly? Errors?

I tried looking at OpenStreetMaps directly - but its a diff map look and feel, so I dont know if its the same


  • OK, 20 min later, all the map tiles are there in the proper quality at the 5km distance. But 20 min? So either its not getting them and its taking forever, or it’s getting them and fumbling them.

Let me know if I can help you guys debug, dig into the cache, turn on a really detailed log, etc.

Thanks for reaching out and excellent reporting! That’s a ton of detail – really helps when trying to get at the root of an issue.

So I was able to reproduce the issue you’re describing – I do notice that if I turn Shields off (or toggle off the Block Ads/Trackers option), the map will load without issue. This points to some tracking element on the page getting blocked or halted which prevents the rest of the map from getting rendered. I’m reaching out to one of our Shields team members right now for a deeper look.

1 Like

Hi @cswanson If you enable “Allow all cookies” in Shields does this help?

1 Like

Have submitted a fix, just needs to be approved


@fanboynz - Yes, allow cookies fixes the problem - and I see you submitted a fix, very cool.

How long do you think before it rolls out so I can test it? No hurry on my end of course, just want to help.

Give it 24-48hrs @cswanson

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.