Brave Uses 81% of Computer Memory

Brave is using 81% of my computer memory slowing it down tremendously. Help!

Hello @BLR51

Thank you for reaching us and I’m sorry to hear you are going through this. Can you try disabling Hardware Acceleration in settings, to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration.

Additionally, please try going to brave://flags > Search 'Vulkan' > Disable Vulkan > Retest Let us know if that helps.

Regards.