Brave taking a full minute to launch


Hi,
I’ve been Using Brave browser on multiple Linux devices for at least a year with no problems. Just a week ago, however, the Snap-based Brave running on my Ubuntu 20.04 laptop (Brave version 1.18.78 Chromium: 87.0.4280.141 Official Build 64-bit) started taking much longer to launch - as long as a full minute.
When I launched from the terminal, I saw these messages:

$ brave -v
Gtk-Message: Failed to load module “canberra-gtk-module”
Gtk-Message: Failed to load module “canberra-gtk-module”
[2144:2144:0116/210623.970067:ERROR:CONSOLE(1)] “Active tab not found”, source: chrome-extension://mnojpmjdmbbfmejpflffifhffcmidifd/out/brave_extension_background.bundle.js (1)
Fontconfig error: Cannot load default config file: No such file: (null)
[2144:2205:0116/210634.832059:ERROR:udev_watcher.cc(97)] Failed to begin udev enumeration.

I suspected the user configuration might have become corrupted, so I uninstalled and installed again. But the trouble persists - even with no tabs from the previous session.
This is a decent laptop that’s more that capable of running the load. I’ve got 8GB RAM and a Kingston SSD drive. There’s no way it should take anything like a minute to load. By comparison, Brave running on my desktop machine loads in less than three seconds with ten open tabs!
Any ideas?
Thanks,

@dlanced ,
Apologies for the late response.
We’ve released an update to version 1.19.88 since you posted this – can you update the browser and tell me if you get the same results in the latest release?

Hi,
1.19.88 is indeed installed. I just cold booted my laptop and waited 30 seconds or so after boot (to make sure the base system loaded properly) and then launched Brave. The only other app running was top.
Brave still took 65 seconds and, strangely, opened as many as six separate processes at a time.
Thanks,

1 Like

@dlanced,
It could be some bad data caught up in the browser causing the slow start up. It could also be an extension that’s installed. Either way, I’m curious – can you try closing any open Brave windows and then opening a Private tab and see if it takes the same amount of time to load?

1 Like

Well, loading in incognito after a fresh boot was faster, but it still took 45 seconds.
I didn’t mention earlier, but shutting down Brave and reopening it in the same boot session is pretty much instant - no matter how many tabs are open.

@dlanced ,
Have you tried clearing your cache/browsing data already? If not please try doing so and tell me if there is any improvement.

I’m assuming that other applications/browsers do not take this long to launch on your machine and Brave shouldn’t either. There must be something mucking up the process.

Can you also try disabling Hardware Acceleration in settings to see if this resolves the issue? You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

1 Like

With hardware acceleration disabled and a cleared cache (and no open tabs) it still takes a full minute.
Firefox and LibreOffice (a well known bloated monster) both took less than five seconds to fully load.
I should note that I’m having the same problem with Brave on a separate desktop machine (although not on my workstation - which is still giving me great performance).

1 Like

@dlanced,
Thank you again for confirming. I’m going to try and rope in some additional team members on this as I’m truly not sure what could be casing the slow launch.

Thanks. I appreciate your help.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.