Brave stopped opening certain websites to where I was linked to

Description of the issue:

  1. Brave [Version 1.21.74 Chromium: 89.0.4389.72 (Official Build) (x86_64)
    ] on MacOS doesn’t open certain links. ‘This site can’t be reached, the connection was reset’ appears. This only happens with some links to some websites and I cannot figure out what’s the difference between them and why one link doesn’t work while others do.
  2. It occurs whether Brave Shields are up or down
  3. Chrome on the same Macbook Pro opens everything normal

Expected result:
Opening websites to where I was redirected. Knowing how to maybe change a setting in Brave that causes this behaviour.
Brave Version( check About Brave):
Version 1.21.74 Chromium: 89.0.4389.72 (Official Build) (x86_64)
Additional Information:
I’ve uninstalled and re-installed Brave to try to solve it but it didn’t work. No error message or any other popup appears.

Hi @SebParacuru, Welcome to Community!
Where are you opening these links from?
Can you give an example URL for one of these sites?
Do you have any extensions installed?

Hi Aaron,

Thanks for your swift reaction!

I’m opening another website from within an e-mail and its URL looks like this:

But also other links won’t open the website they redirect to…

For example, when I search for PC’s in Google a search results-page opens with a row of sponsored ads from different stores offering PCs. The link to one store opens normally, yet from another store the link ‘links’, but the webpage gives the same error message.

When opening ‘Extensions’ in Brave settings there are some options but when I open ‘Manage extensions’ apparently I’ve got nothing installed.

Please have a look on the screenshot I’ve included. Brave states the connection to the site is not secure, while these sites are bonafide and with https:// URL. Also, Chrome opens the same website with the same link without any problem.

I really think it’s a setting but I can’t find which…

Please help me out!



This could be an issue with Brave Shields and trackers within the links. Which mode do you have on in Brave Shields? Aggressive or Standard?

Hi Daniel,

Thanks for your mail. It’s set on ‘standard’. The odd thing is I’ve never had this before with Brave and/or the source-site and I’ve changed nothing in Brave settings (deliberately). Very strange…

Thanx for your help!

Stay safe!


Would you try something? Create a new user by going to the three bars in the right-hand corner, and clicking create a new profile. Then try it. Just to test. Because I am not having the issue on my end.

1 Like

Definitely seems like a caching issue to me. Please try what @TheGreighCanary suggested and create a new browser profile (be sure to close the original browser window, such that you only have one Brave window open using the newly created profile) and test the same links to see if they work in the new profile.

1 Like

Thanks very much everybody who tried to help… Miraculously Brave functions completely normal today… Opens everything normal… Maybe just a glitch of the universe! :wink:

1 Like

Date: March 11, 2021 - I have read the post and replies for this thread. SebParacuru said that he is not having any issues presently, and his post was dated January 9, 2021, I believe. SebParacuru’s post seems similar to the problem I am having:

I have not been able to log in to my email. I use a Macbook pro (2018), Brave browser which is the most updated version, and hadn’t had any problems prior to about two days ago logging in to this e-mail account. Usually when I am in Brave, I make sure to set Brave preferences to “Cookie blocking: Cross site only” and that is usually all I need to do to access my email account, then change back to Cookie Blocking: All when I am done with my e-mail. Now when I do the change in preferences, I login with my password and a window comes up saying, “Your browser is a bit unusual. Try disabling ad blockers and other extensions, enabling javascript or using a different browser.” So I called GoDaddy customer service where my e-mail account is set up. The rep couldn’t figure out what the problem was. I did make sure that the Brave browser is the current iteration, and it is. A new thing I tried was Tracker and Ad Blockers: Disabled. I had never had to change that before. Still could not log in to the email account.
Can anyone give me a clue why this problem might be happening?

When you change the setting, are you changing it in Settings --> Shields? If you’re trying to change Shields settings for a specific site, you should do so in the Shields panel, located in the address bar (lion icon). These changes are specific to the site you’re on, whereas the options in Settings is a global setting (that is, any website you visit will default to these settings, unless you’ve altered the Shields panel settings for the site).

So if you go to sites that throw you the error, like outlook, change the setting in the Shields panel instead of globally and you should be good to go.

Mattches, thank you for your reply. I tried what you suggested and it still is giving me that sort of an “error” window. I am in Shields, have always used that to change preferences in Brave. I never had to do it for each site I visited. But, apparently I have to do that for each site on my cell.

So, I have always changed these preferences under Shields on my computer, but something is different now, and this new error window comes up even if I go into Preferences, Shields, Cookie blocking: Cross site only" then login to email in that tab or window where I made the preferences change.

I even tried under Shields, Tracker/ad blocker: Disabled and Cookie Blocking: Disabled and it still gives me this error message.

To add to my reply to Mattches above: I went to the email account site, clicked on the Lion icon and tried setting preferences there to those that I indicated above, and after entering the password, I still get that same “error” window.

Also tried accessing my e-mail by setting up a new brave profile after closing all browser windows (suggested by Mattches), experimenting with Shields settings under the Lion icon while at that site, and after entering the password, I still get this maddening error window.

the website wants to apply things you are blocking or visa versa now brave protects itself.

Would you be willing to share a screenshot of the error, just so I’m on the same page as you with what the behavior is?

Mattches, here is a screenshot of the “error” page I am getting

Thank you for taking a look

I’ll need to sign up to a godaddy account, what (exact) steps do I need to reproduce this error @ElizaT ?

1 Like

I have this outlook office 365 account with godaddy, and my domain name and access the email by going in to the login page and entering my email and password. As soon as I enter the password and hit Return, I get that “Your Browser is a bit unusual…” window.

Hope that helps?


I briefly saw it, but not easy to replicate.

If you add @@||^$script,first-party into brave://adblock does it help?

fanboynz, Sorry, I am not sure what it is you are talking about. When I go into Brave preferences the url at top just says Brave://settings