Brave issue with opening links in Chromium on MacOs Big Sur

I have problem with Brave after update of mac os to Big Sur.
The problem is with opening links from any communication app, slack, mettermost, viber, telegram even email, it opens chromium browser instead of brave browser.

Can you please advice how to solve this issue?

thanks :slight_smile:

Hi @lazarvgd, Welcome to Community!
Can you go to System PreferencesGeneral and double check Brave is set as the default browser?

It already is default browser :slight_smile: . I see that is chromium installed with brave, but the problem is that I do not see chromium among installed apps, but when, for example, open notification centar it shows Chromium notification settings alongside with brave.

Thanks

Same problem for me after upgrade to Mac OS Big Sur. Very irritating

Brave is default system browser (double checked in Brave preferences and system defaults, tried changing to another and but). Links from any apps are opened in clean Chromium window

1 Like

Mine does this as well. I noticed it only opens in chromium if another application on my big sur mac is running. Any workarounds?

Brave is the default browser. I noticed that chromium only opens if I am also running another application that uses jxbrowser. The Mac OS is opening links in a blank chromium window only when this application is running, even with Brave as the default browser.

I cannot tell is this due to other applications or not. I am running two mail clients, mettermost, viber amd telegram chat apps, android studio, fork git client, deezer music player and other apps… But it is happening whenever I am opening the links from mettermost or other chat apps and email clients

I didn’t find workaround for this, except using FireFox as backup. Waiting for moderators @Aa-ron to respond…

I believe it is other applications and Mac OS saying ‘yup, thats chromium’ and just opening chromium. When I am not running the application I have that uses chromium, all links resume opening in Brave.

Hello all,
I’ve reported this issue to the team, I’ll let you know if I get an update on this.

@lazarvgd, can you confirm - you’re saying links open in chromium and not chrome?
Do you have chrome installed?

@brandonso1 @qwertyway - can you also confirm if links only open in chromium and not chrome or any other browser?

Links will only open in chromium. Activity Monitor shows that a chromium instance is created rather than chrome. I do have chrome as well on mac however it does not open chrome

If Brave is NOT the default browser, then links open to whatever IS the default browser

@brandonso1, thank you for letting me know

I also confirm that’s “chromium”

What’s strange, yesterday for half a day everything worked fine and links opened directly in Brave. Today it’s started again. I tried closing all other suspicious apps as @brandonso1 suggested, but it didn’t help