Brave sporadic crashes

Description of the issue:

Brave started crashing “all” the time today (9/9/2020). It crashes if I try to start a video on youtube, and it crashes if I try to visit github.

Tried to google the problem, but had no luck.

How can this issue be reproduced?

  1. Brave version [Version 1.13.82 Chromium: 85.0.4183.83 (Official Build) (64-bit)
  2. Go to youtube -> start any video -> crash
  3. Go to brave://crashes/ -> Provide additional details -> crash

Crash report IDs:

19280000-88e8-0505-0000-000000000000
16280000-88e8-0505-0000-000000000000
b3270000-88e8-0505-0000-000000000000
b1270000-88e8-0505-0000-000000000000

@Thorstein,

Can you try disabling Hardware Acceleration in settings to see if this resolves the issue?

You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

Hi @Mattches,

Use hardware acceleration when available is off, and youtube still crashes.

Report ID:
0c2e0000-88e8-0505-0000-000000000000

@Thorstein,
Have you tried clearing your cache/browsing data for Youtube? Do this by visiting the site, clicking the Lock icon in the address bar, then Site Settings --> Clear data (note you’ll have to refresh the the site after doing this).

This kinda did the trick. I tried going to the Lock -> Site Settings -> Clear data and restarted Brave, but it did still crash.

However I opened the Developer Console then Application -> clear storage and also cleared Local Storage, Session Storage and Cookies. It’s now working :smile:

//EDIT:

Sorry, it did not work. It “worked” for a couple of minutes, and now its back. Crashing on youtube, and I can’t even open Github.com.

Crash IDs
e4320000-88e8-0505-0000-000000000000 -> Youtube video
e6320000-88e8-0505-0000-000000000000 -> Github.com

Re-installed Brave, now everything works again.