Brave shows random text in some websites

I have shown two screenshots of the same website, the first one on Brave and second one on Chrome. I have shown for a single website here. But, have faced this issue in several websites, mostly academic ones.

@swo0sh I just tested on my browser and things seem to load properly.

Could you try 2-3 of the basic troubleshooting steps and report back on whether you see any changes?

  1. Try opening in private window. (this opens an instance with no cookies, but also should have all extensions disabled by default) If it loads fine here, it’s a coin toss as to whether it’s a cookies related issue or extension.

  2. Add a new browser profile (Hamburger Menu imageMore ToolsAdd new profile). This creates a second profile with most default settings and no extensions. If it works here, it generally suggests an extension is the culprit, but secondary is something in your browser settings.

  3. Turn off Shields. Any change?

Also, would help to know:

A. Which version of Brave are you using? (provide exact version number please)

B. Which Mac OS are you using?

I tried all of these but it didn’t help. I didn’t have any extensions on in private mode. Also, the new profile didn’t help. Similar for turning off the shield.
Brave Version: 1.63.162 Chromium: 122.0.6261.69 (Official Build) (arm64)
MacOs Version:

ProductName: macOS
ProductVersion: 14.3
BuildVersion: 23D56

Well phooey, of course not. I went to do some research and came to find out that Uhqst'khy'shnm and all as you are seeing generally appear due to font rendering issues.

I’m going to try to tag in @Mattches to see if he can check things. But in the meanwhile, would you try the following steps below just in case it might resolve things?

  1. Can you go back to and install on top of your current version? To be clear, don’t uninstall anything. The purpose of this is just to patch anything that might be missing or corrupt in your current Brave.

  2. Check brave://components and update everything there.

  3. Check out your settings at brave://settings/fonts. If you change fonts, does it resolve?

It seems like this is the issue:

I changed it to Times Roman for now, and it is working.

Thanks a lot.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.