Brave private window will not open unless there is a Brave normal window iteration already running on any currently open Windows Desktop

2022-11-03 10:30 EDT

Description of the issue:

Brave private window will not open unless there is a Brave normal window iteration already running on any currently open Desktop.

Details: (On Windows 11 Home, 21H2, OS Build 22000.1098)

  1. With no iterations of Brave running on ANY open Windows DESKTOP, fresh off a windows restart and basically nothing running but background tasks

  2. Right click Brave Icon on task bar and from resulting context menu, select NEW PRIVATE WINDOW

  3. Response: Nothing… no window or Brave iteration opens at all.

Steps to Reproduce (add as many as necessary):

  1. Restart Windows, terminate any ‘additional’ windows Desktops (just to keep it clean and simple)

  2. Right click Brave Icon on task bar and from resulting context menu, select NEW PRIVATE WINDOW

  3. On both my PC’s (Win 10 and Win 11) the response is: Nothing… no Brave window, private or otherwise, opens at all.

Expected Result:

A new Brave Private window should open.

Reproduces how often:

Consistent and Always and it has been that way through many updates of Windows and the Brave engine.

Brave Version:

Brave Version 1.45.118 Chromium: 107.0.5304.91 (Official Build) (64-bit)

Reproducible on current live release (yes/no):


Additional information:

This is true on Windows 10 (Win 10 Home, 22H2 19045.2130, exp Pack 120.2212.4180.0)

and on Windows 11 (Win 11 Home, 21H2, OS Build 22000.1098, exp Pack 1000.22000.1098.0)

- Note: This issue is ‘annoying’, but not critical. The simple bypass is to first open a normal Brave browser iteration, then opening a Private window works using either the task bar method or the MORE OPTIONS menu method of the normal Brave window.

I just tested on mine. All Brave tabs closed. I right mouse click on the icon in my taskbar, hit New Private Window and only one window opened and it was in Private. This always has worked for me, originally on Windows 10 Pro and now on the newly updated Windows 11 Pro.

In saying that, it suggests it’s a setting or program on your computer that’s causing your issue. What it might be though, I’m not quite sure. Hopefully @Mattches might have some sort of suggestion for you.

Thanks for your reply. Tell me, please, when you say “all Brave tabs are closed”, does that mean that you have no BRAVE browsers running at all? What I mean is, if you go to TASK MANAGER, and check the running tasks, there should be NO BRAVE tasks showing up in the Name column.

Correct. All windows and tabs with Brave is closed.

Now you’re talking something different. Originally you said Brave private window will not open unless there is a Brave normal window iteration already running on any currently open Desktop. Are you saying something else now?

That said, Brave will have auto update running but not any instance of Brave going.

Other thing to keep in mind is that you have the option to keep Brave running in the background. But again, that would NOT be as you phrased it in your OP in that it won’t have a normal window running first. What you would have running is the part of Brave that needs to be going in the background to serve ads and everything.

You can go to brave://settings/system to adjust those settings to prevent Brave from running in the background if you don’t want it to.

Right. Already checked those settings and have exactly what your screen shot shows. So, the only other superficial difference that I can see now is that you are running Windows PRO, whereas I am running Windows Home (both 10 and 11). Time for me to start digging deeper. Thanks again for your responses.

Thanks for reaching out. I’m also unable to reproduce this on my Windows 10 machine. It seems unlikely that this would be the cause, but can you confirm whether or not you have any extensions installed in the browser when testing this?

If so, can you try disabling them then testing again? If you get the same results, can you try downloading the Beta Build and trying to open a Private window on Beta using the same steps as you would normally (from the context menu)? Note that installing/running the beta will not interfere with your current installation in any way.

Thank you for your consideration of this issue.

Yes, I have extensions normally activated. I did disable them and retried the Private Window launch, and it worked fine. I reactivated this extension: “DuckDuckGo Privacy Essentials” and the problem returned.

So, for others who may have this same issue (I know there are some…) this is worth looking into as a solution.

Thanks to all who have collaborated.

Yep, deactivating that extension worked.

So much for “DuckDuckGo Privacy Essentials”. Wonder how long it’ll be before anyone with the ability to fix it (or Brave, whichever) is told (and much, much later) comes to believe that this issue exists.

By the way, since when does having to ditch an extension equate to an issue being “solved”?

I agree with you, RRETTER; it’s not resolved, just understood. There were no other selections to say that we found a “bypass” or a “compromise” so if folks find this problematic, I imagine that they can pursue with DUCKDUCKGO folks and / or the Brave folks for a true solution.

@rretter and @Elwy you’d have to contact DuckDuckGo and have them modify their own extensions. It’s not up to person who makes the web browser to try to figure out the code for an extension and then rework their browser to fit it. Extensions are extra that you’re adding on a browser and they always carry risks. Whether it be to create a security risk for your device, to break code, or anything else.

So if DDG has this conflict, then it’s either up for them to have to adjust or for you to decide not to use them.

Thanks for your comment, Saoiray. In fact, I did send a note to DDG support as soon as it was clear that the rogue behavior was with their extension. I have not had a response. For me, this is no longer an issue.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.