Brave only launches a blurry image on startup after IOS update

When I launch Brave I only see a blurry image that is unreadable
This started the day after my iPhone 12 Pro Max received an update from Apple to IOS 14.6

Expected result:

Brave Version( check About Brave): I can’t read the initial screen

Mobile Device detailsiPhone 12 Pro Max

Additional Information:
How do you recommend I correct this? Should I delete Brave from my phone and then do a fresh install from the app store? Thanks in advance for your help.


Hello? It has been 26 days since I posted this. Do the Brave Support Staff monitor this board? My problem still exist.


What can I expect if I delete the app and then re-install it? I have a sync phrase saved that I can use to sync my new Brave but have never done this before. Anybody here ever done that? If so please share your experience with how it went.

I have done the sync thingy… And it does work…

But when I did it, Brave was still installed on my pc and I synced into my phone.
So I think for safety u should first use the Phrase code on pc then reinstall Brave on the phone…

Also that Code doesn’t backup you BAT Coins if you have any accumulated…

Hey @jimc91 !

This is strange, can you try uninstalling and reinstalling Brave? If you have enabled Sync you should be able to retrieve the things you enabled for Sync using that passphrase.

@ItzMeRajat iOS does not support Brave Rewards at this time.

Hope this helped!


This is getting more strange… I tried to delete brave and reinstall it but when I go to the app store to download it all I see is open, like it is still there and did not get deleted. Any suggestions???

Ohh I see…
I don’t like iOS anyways

Hey @jimc91 !

I have just been notified that the blurry background looks a bit like you setup a PIN. Have you done so?


I just started having this same problem on iOS. I’ve tried force-quitting Brave and restarting my phone, but the app only shows that blurry image when it opens. I can’t tap on anything or interact with the app in any way.

I do have a PIN set, along with Touch ID enabled. It prompts me for my fingerprint, unlocks, and then just shows that blurry image.

I upgraded iOS from 14.2 to 14.6 yesterday. I updated Brave to 1.28 just now, but the problem continues.

Obviously, the app is unusable now, so I hope Support can help!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.