Brave on M1 MacBook broken

Since this morning, Brave has appeared like the attached image - every webpage and the whole browser just looks completely broken making it completely unusable.

This has only been an issue with brave and not any other application (not even Brave Beta). I am on the latest version of Brave [Version 1.20.110 Chromium: 88.0.4324.192 (Official Build) (arm64)].

I have tried restarting my Mac and re-installing Brave, but it didn’t help. I guess the only other thing that I could try is reset Brave to factory settings.

Weirdly, the issue doesn’t appear when I drag the Brave window across to my external monitor.


Can you try disabling Hardware Acceleration in settings to see if this resolves the issue? You’ll find this in Settings --> Additional Settings --> System --> Hardware Acceleration

I’ve also reached out to the team for more information about known issues with the M1 machines as I know we’ve had some, but they should all be resolved by now. I will reply when I have more and please let me know if disabling HWA has any effect.

I just reset to default settings which didn’t seem to fix anything.

I then restarted and everything seems fine now.

Thanks for your help :slight_smile:

1 Like

Well that’s fantastic!
I’m going to leave this thread open for a bit in the event the issue shows back up again. Please do reply if it does.

Okay, turns out the issue wasn’t actually fixed but disabling hardware acceleration has properly fixed it now.

1 Like

That’s great news – thank you for replying back and confirming. Will continue to leave the thread open a bit longer just in case :slight_smile:

1 Like

My screen was freezing intermittently on an iMac 2020, 10 core 10th gen i9, 11.2.2.and an . i7 4 core 10.15.7. This solution fixed the problem.
Thanks for leaving this open long enough to be found.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.