Brave is preventing Royal Mail Postcode Finder from working

Description of the issue:
I tried to find a postcode with Royal Mail Postcode Finder and the dropdown box doesn’t appear. Hitting return doesn’t work. Went back to Google Chrome and it works fine. I like Brave but my use of it will be shortlived if it doesn’t work with all my websites. Also directs me to the American ebay rather than the UK version; Google Chrome gets it right!

Steps to Reproduce (add as many as necessary): 1. 2. 3.

Actual Result (gifs and screenshots are welcome!):
As above - the dropdown box won’t work unless the Brave Shields are cancelled which sort of defeats the purpose of using Brave.
Expected result:
I want to be able to use Royal Mail Postcode Finder - but I don’t get this result.
Reproduces how often:
Operating System and Brave Version(See the About Brave page in the main menu):
Windows 10 and Version 1.7.98 Chromium: 81.0.4044.113 (Official Build) (64-bit)

Additional Information:

Can you try enabling allow all cookies in the Shields panel?

You can alter the Shield settings for each site you visit, so each site has their own settings.

No I hadn’t tried that. I’m new to Brave and not pc-literate so wasn’t aware of that. Many thanks. Appreciate it.

1 Like