Brave hangs (after visiting a site) every time I open it (Android)

So I went to an online radio site and after ± 30s my browser hanged and was unable to resolve itself. Closed it and tried to reopen it but it would still hand instantly. Tried to force stop it, restart my phone as well as reinstalling brave itself but nothing works. The only difference was after the reinstall: instead of the browser hanging on a black screen it now hangs on the first brave (send optional data checkbox) window. Anyone know what I should try to do now in order to fix this?

4 Likes

Having the exact same issue just now.

Was watching a YouTube video in full screen. The audio kept playing but video froze.
Tried closing and reopening and started just showing a blank tab with nothing clickable.
Tried rebooting phone, still the frozen blank tab.
Tried deleting cache and data.
Tried reinstalling.
Now also for me it hangs in the first screen and when I swipe away it opens and closes straight away.

Brave seems totally dead on my Android OnePlus 7 pro phone now.

1 Like

Same here, I cannot even access the Manage data setting

2 Likes

1 Like

Yes, seeing the exact same issue here after updating to the latest release on the Google Play store :frowning:

1 Like

Brave stopped working on all my Android devices. I tried uninstall and reinstall but as soon Brave open up it freeze and i get a “Brave is no longer responding” after a few seconds.

1 Like

I have exactly the same issue. Tried different old versions of Brave, but the error occurs everytime on my Google Pixel 3A (Android 12).

1 Like

Same issue here . I tried different versions . all the last having same issue.
Th only one that worked as 1.5.5 from 2020

I have the same problem and I have found a solution.
First you need to enable developer’s options.
Head over to option called something like “Preferred GPU Driver” (pol. Preferencje sterownika grafiki).
All the apps there should have written “default”.
Then you need to find Brave and select “System GPU Driver” (pol. systemowy sterownik grafiki)

After all these steps, it works again. Good luck everyone.

3 Likes

Thank you ! this is the right temporary solution

Brilliant! I can confirm this works. The problem occured with every Android playstore Brave version. Stable, beta, and nightly.

Description of problem:
Brave opens a blank window or the initial privacy check box, but is totally unresponsive. No settings can be opened, nothing can be typed in search/url bar. After around 10 seconds it cashes completely. Issue persists across reboots, and uninstall/reinstall, on all Brave Android channels. Issue first occurred 31/10.

Temporary fix:
Enable developer options (Settings->About Phone->Build number then tap 5 times on Build number). Then go into Developer Options ->Graphics driver preferences->Brave, and switch from ‘Default’ to ‘Sytem graphics driver’

1 Like

It didn’t work for me. Hope for a fix soon

Problem has resolved itself by me. Fix no longer needed. Not sure what was changed, because I don’t think there was an update, but it works again. Strange.

1 Like

Does not work on OnePlus 7T.

Have you tried uninstalling and reinstalling Brave?

Yes. No luck. Started with clearing cache, reboot, reinstall… and now the GPU setting.

After a reboot and reinstall, Brave started to work again. Could it be a bad PlayStore release?

I think there could have been some issue with one of the URLs that Brave calls , like:

componentupdater.brave.com
go-updater.brave.com
variations.brave.com

I see quite a few calls to those endpoints yesterday when this issue happened.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.