Brave hanging on start after update

Brave prompted me to update to the newest version, so I did. Upon restarting after the update, it hung & I had to force quit.
I tried again, same thing.
I tried from command line, using --incognito --no-extensions
Same result. It presents the window and immediately a spinning beach ball and never recovers. I have to force quit.


More info: I’m on Ventura 13.2.1
I have no idea what version of Brave was installed.
I decided to try downloading the latest .pkg from the website & install it over what was there.
Same result.

@sampson Please look into this. Thanks so much!

Hi @jedigrover

Thanks for the information, I’ve shared this with our team and I’m waiting for further information on the matter. Once our team has answers, we will get back to you as soon as possible.

Have a great day!

Thank you! I updated MacOS to Ventura 13.3.1 and the behavior is the same.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.