Brave Freezing + Beachball of Death on MacOS Sonoma

Description of the issue:
Brave browser keeps freezing followed by the beachball of death that remains indefinitely on MacOS Sonoma. The only solution is to force quit Brave and open it again. It happens frequently whenever I switch between tabs or between windows. Before the freezing, I can observe a considerable lag in the response of the browser.

The issue started happening recently (~ 2 weeks ago) after a combination of updating to later versions of both Brave and MacOS.

How can this issue be reproduced?

  1. Open Brave browser
  2. Open multiple tabs
  3. Switch between the tabs and other programs running on MacOS

Expected result:
No freezing

Brave Version( check About Brave):
v 1.61.104

Additional Information:
OS: MacOS Sonoma Version 14.2 (23C64)
Device: Macbook Pro, Apple M2 Pro, 14 inch, 16GB RAM
Brave extra settings: Two browser profiles

What I tried:

  1. Restarting Computer
  2. Resetting Brave

I have had a similar problem. I have a MacBook Air (2017) and Brave froze on me three times in a row. I kept restarting it but I kept getting the “beachball of death” as a reward for my efforts. It has started working now, but I’m writing this report on Firefox just in case. Not sure what happened. A glitch? Hopefully it doesn’t happen again. It is very disruptive to my work to have the entire application shut down on me.

After investigating and trying different stuff, quitting the Grammarly desktop app solved it for me. I think the interaction between the Grammarly Brave extension, the browser, and the desktop app created bugs for the browser and ate up resources.

Thank you for the tip! I’ve shut down Grammarly Brave extension, so I will see if that solves the problem.

Blast–that didn’t work. It’s still freezing on me continually. I’m about ready to throw Brave down the toilet and go back to Firefox.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.