Brave doesn't download files

Description of the issue: When i click a download link, it doesn’t download it. Doesn’t show on the download page or like a blank file on mi computer. I tried this on Google drive, a random image and some random websites

Steps to Reproduce (add as many as necessary): 1.Click a Download link (if downloading an image, right click and “save image as…”); 2. It does a quick flash, like if it ignored the browser for a second and then went back to it; 3. Nothing else happens

Actual Result:

Nothing else happens on screen. The “select location” dialog box doesn’t display

The same thing happens in every page, including google drive links

Nothing appears in this page

Expected result: Download starts.

Reproduces how often: Every time i try to download something

Brave Version(about:brave): Version 0.64.76 Chromium: 74.0.3729.157 (Official Build) (32-bit)

Additional Information: My computer is kinda old. Also i tried downloading files in Chrome and it works

1 Like

@Dekey can you please add another info about your issue as described here?


Sorry, i didn’t knew there was templates hahah. Done

1 Like

Looking into this now. Can you tell me what OS you’re using?

Testing on my end, I’m able to download images and files without issue (macOS 10.14.4, Brave v0.65.76).

Can you launch Brave and navigate to Settings --> Advanced --> Downloads and confirm that the location downloads are pointed to is valid? Additionally, do you have the option to Ask where to save each file before downloading enabled or disabled?

Windows 7. My computer is pretty old i guess, maybe the issue is outside Brave?


Ooph, yeah. Windows 7 and Brave aren’t great friends.
Next thing to try would be to clear your browsing data.

Not sure if you have history or specific cookies you want to keep, but I’d recommend clearing most, if not all, browsing data for All time if possible.

Menu --> History --> Clear browsing data

1 Like

Nope, it does the same thing.

The plot thickens.
May seem weird, but will you open a Private window (and/or Private w/tor) and try to download something?

I didn’t notice before but it shows a little bit of progress for a second, then goes back to normal. This happens in all kinds of windows
Still, nothing is being downloaded

This is a Private window with tor, still the same thing

The same also happens without thor.

Could there be something external that’s affecting Brave? because Chrome downloads work fine :upside_down_face:

With chrome.

1 Like

Let me dig around and see what I can find. Thanks for your patience.
Have you moved any of the Brave install files since you’ve had it?

Thank you for helping me out! :yum:

No, not at all

Also little update: it looks like it doesn’t happen only with downloads, but with uploads as well, since i wanted to put a profile picture here, and the same thing happens. Again, tried to do the same on chrome but this time it doesn’t let me there either. I did the same thing here and on Twitter on both browsers

In brave: can’t download or upload
In Chrome: can download (double checked) but can’t upload.

Any A/V services running in the background? Also, what’s that extension installed – if I can ask?

So i’m thinking it’s surely a problem on my computer, but i don’t know what is it

Yes, Avast Antivirus.

The only extensions i have are “Brave Shields” and “Brave Rewards”, wich i’m not really using

1 Like

Oh I see – I thought this guy was an extension:

That said, can you try creating a new profile (or use guest I if you’d like) and saving a thing?

Sorry i didn’t replied earlier. I fixed the problem by uninstalling some random programs that i didn’t use, one of them being chrome, if that’s usefull.

Sorry for wasting your time :worried: i hope this was usefull for somehing else



No worries at all – wasn’t a waste! I got this job due to my love for problem/puzzle solving (and hypnotizing everyone who interviewed me) so I had fun :slight_smile:

Please don’t hesitate to reach out if you have any further questions or concerns.

1 Like