Brave crashes immediately after completing brave://welcome screens

Description of the issue:
Brave began crashing repeatedly when some websites were opened. Unfortunately, it crashed immediately when attempting to open the settings page. I attempted to uninstall Brave, wipe my local settings, and reinstall. However, now Brave crashes as soon as I complete the brave://welcome screens.

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Uninstall Brave
  2. Remove all local settings including the following directories:
  • /Users/bgladwell/Library//Application Support/BraveSoftware
  • /Users/bgladwell/Library//Saved Application State/com.brave.Browser*
  • /Users/bgladwell/Library//WebKit/com.brave.Browser
  • /Users/bgladwell/Library//Caches/com.brave.*
  • /Users/bgladwell/Library//Caches/BraveSoftware

Actual Result (gifs and screenshots are welcome!):
Upon launching Brave and completing the brave://welcome screens, Brave crashes immediately.

Expected result:
Brave should not crash.

Reproduces how often:
Every time when using the steps above.

I did try completing the last welcome step by not turning on Brave rewards. This allowed me to get to a blank page. However, as soon as I tried to navigate to a website, Brave crashed. It also allows me to get to the settings page, where I turned on automatic crash reporting. However, after clicking around in settings for a minute, Brave crashed again.

Operating System and Brave Version(See the About Brave page in the main menu):
macOS 10.15.6
Brave Version 1.11.104 Chromium: 84.0.4147.105 (Official Build) (64-bit)](

Additional Information:

Can you tell me if you have had Brave Sync enabled in your browser?

@Mattches - thanks for checking on this.

It is possible I had Brave Sync enabled, yes. I remember messing with it a couple months ago and then finding out it wasn’t yet available on mobile. But I’m not sure. It looks like it’s not available in settings in the current version I have installed.

Can you try launching the browser from the Terminal, using the following command:

 open -a "Brave" --args --disable-brave-sync

and see if the browser launchs/stays open normally?

@Mattches - I just tried that. Started Brave with that command. It crashed a few seconds after being opened.

@Mattches - any other ideas? I miss Brave!

Can you try re-running the installer (if you don’t have it anymore you can re-download it here), which will apply the latest updates? I want to ensure you’re running v1.12.112 and that the problem still persists when using it.

@Mattches - I re-installed (I’m not sure what version I had before). I now have v1.12.112 and everything seems to be working again.

Thanks! - Ben

1 Like

You’re very welcome :slight_smile: