Brave Browser: Twitter web Log In Black Screen window slip-up

Greetings to the community, I recently encountered several errors when logging into Twitter from the Brave browser. I put my personal data but it gives me a black window and trying to start with my Google email or Apple ID it responds with a similar error but request cannot be completed.

I followed the suggestions to resolve the error in Touern13’s Aug 28 closed post, but the contraption still stands. I use the browser Brave Version 1.45.116 Chromium: 107.0.5304.91 (Official Build) (64-bit). None of this happens to me when tried using the Google Chrome browser. :wink:

These are my system properties:

Device name DESKTOP-HMB1365
Processor Intel(R) Pentium(R) Gold G5420 CPU @ 3.80GHz 3.79 GHz
Installed RAM 4.00 GB (3.87 GB usable)
Device ID 81862ADF-E7AA-458F-ADB0-FBD162CD10A9
Product ID 00326-10000-00000-AA480
System type 64-bit operating system, x64-based processor
Pen and touch No pen or touch input is available for this display

I look forward to your prompt assistance, thanks in advance.

Try testing in private window mode, no extensions. Also clearing cookies/cache in brave://settings/clearBrowserData

Hello fanboynz, I tried to log into a private tab with my personal data, all extensions disabled and browsing history deleted and the glitches continue. The same by logging in with Google or Apple.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.