Brave Browser showing some adverts

Hi there
I started using Brave Browser as the Newcastle Falcons forum I was using was constant adverts.

Brave browser cleared all of those for me until today.

Now I see to be back in the advert hell I was in previously.

Can anyone tell me if there is a setting which I am not using in Brave which can prevent the image below.

The advert goes across the top and all down the right side of the page.

@Aidanb When you create topics here, you need to choose categories. Underneath where you typed in the title, you would have chosen a Category (where it says Uncategorized)

Doing that makes sure it gets to the right people who can help you. In addition, it inputs a template for information we need you to provide. For example, yours would be adblock. What I can’t tell though is which device/OS you’re using. Is that iPhone or Android? I’m wanting to assume iPhone, but yeah…kind of important to know.

Just help by clarifying the following:

  1. Which version of Brave are you using?

  2. Which OS is this on?

  3. What settings are you using for your Brave Shields?

  4. Can you provide direct link(s) to where this is occurring? (I see one of the things says rugbynetwork.net but on the tab it says FalconsRugby.org so just trying to figure out places you’re at)

Just a FYI, I’m editing your Title because the current one says “not showing adverts” but your complaint is that ads are showing. I’m also going to go ahead and move this over to the correct category.

1 I have no idea how I would find that out - sorry

2 I’m using iOS 15.5

3 same as 1 above

4 https://m.rugbynetwork.net/boards/list/s95.htm?97

Sorry that I can’t be helpful with 1 and 3.

On iPhone you find out Brave version by going to your Settings (which is the three dots on bottom right) and then click on the word Settings, then you scroll down to where it says Version and the number. If you’re using most recent for iPhone, it would be 1.41 which was just released like 2 days ago. If it’s not, make sure you go to the App Store and update it.

Two ways. On the site if you tap the lion icon, it will show whether you’re blocking trackers, phishing, scripts, fingerprinting, etc. On other devices, you can choose how strict each of those are, but iPhone is limited.

The other way to have checked is hamburger menu (three dots on bottom right) then to Settings and then to Brave Shields & Privacy. This one will be your default settings for everywhere you visit. The lion one is settings for that particular site (unless you tap the Change global Shields default part)

Just a FYI, iOS 15.6 is out now, so you may want to check if your phone can update to it.

Anyway, I’m on my PC right now. Going to send this reply, grab my iPhone, and test that website out to see if I have issues and if any particular setting matters. Just so you know, iPhone ad-block is horrible compared to Android, Windows, etc. This is because they aren’t able to run some of the scriptlets and all on iPhone that would be needed for the best filters.

Tested the site out on my iPhone 13 Pro Max running iOS 15.6 and Brave version 1.41
As you can see, just had the basic Phishing and Cross-Site trackers enabled. I probably should change Fingerprinting to On, but that’s a different topic, lol.

Try to make sure you have everything updated, Shields indeed is turned on and that you also have Block Cross-Site Trackers enabled.





Thanks for your help on this

I have the same settings as you and ive now updated my phone to ios 15.6

i logged out of the website and back in but that awful advert wrapped around is still there