Brave is no longer blocking ads on any site (PC, Windows)

Brave is all of a sudden not blocking ads on any website I view (PC, Windows, Browser),,

Screenshot of the ad as it appears in Brave
Did the issue present with default Shields settings? (yes/no)

No, it still plays the ad regardless if the shield is on or off.

Besides blocking all scripts, none of the websites have stopped functioning

On my phone, youtube vanced still works (and I haven’t found any issues of ads popping up on my phone neither)

Re-downloaded brave to the latest version to make sure

I have never played around with shield settings and everything was working fine until I came back from a movie and all of a sudden the flood gates opened and every website seems to be sneaking past the shield. Is there anything that could help?

1 Like

Hello there @MK9rocks please accept my apologies for this inconvenience. Please provide the following information in order to investigate further:

  1. Description of the issue:

  2. Steps to Reproduce (add as many as necessary):1.2.3.

  3. Actual Result (gifs and screenshots are welcome!):

  4. Expected result:

  5. Reproduces how often:

  6. Operating System and Brave Version(See the About Brave page in the main menu):

  7. Additional Information:

If you are still seeing ads you can enable these shields filters Fanboy Annoyances List and uBlock Annoyances List to block most ads and trackers on the web. To select them click on this link brave://settings/shields/filters then on filters list, search and check on the boxes corresponding to the ones mentioned previously.

Be waiting for your response.

Same is the problem that I am facing with my browser.

1 Like

@metakunal could you please double-check that you have the latest Brave version installed to see if that’s causing the issue? You can check it here brave://settings/help

Let me know if that works.

Updated to latest version. No reason to have Brave as my browser if ads are not going to be blocked. I have added the security website address as I was told to. I may as well use my old browser instead.

1 Like

@matto you can also set your shields options here brave://settings/shields like this:

  1. Trackers & ads blocking Aggressive
  2. Block fingerprinting Standard
  3. Block cookies All

Let me know if that works for you.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.