Brave browser puts restricted mode on for youtube.com

I’ve had this problem for a while where my brave browser puts my youtube.com account on restricted mode. Someone else was having this problem but mine is a much more severe case. I tried what they said which was to clear cookie. Nope. Incognito mode works for unrestricted mode but its only when I’m logged into my account. No other devices are like this when they are logged into the same account.
https://i.imgur.com/JVoZ4gE.png IMG from brave browser
https://i.imgur.com/5OnhjHd.png IMG from google browser
Both on youtube.com and both are on the same account. The only problem that I’m facing is that sometimes it will do this and sometimes it wont. I haven’t noticed a pattern from when or when it doesn’t do this.

That suggests it’s an extension you’re using. Did you install any extensions to Brave? If so, perhaps try turning them all off and then testing? If it works, then go one extension at a time until you find what’s causing issues.

Just FYI, that tells you the setting ONLY is valid on that browser. So you’d have to log in and check setting there on your Brave browser.

Might have other questions or suggestions in a bit after you give more feedback, but do check those things out really quick.

Hi

The issue may be caused by:

  1. A secure DNS: test with a public dns such as google 8.8.8.8, 8.8.4.4
  2. An extension: Disable extensions one by one until you get the one that may be causing the problem.