Brave blocks requests to my backend endpoints

Description of the issue:
I have a Frontend in React (JavaScript) and Backend in NodeJs (Serverless Architecture in AWS).

Frontend makes request to… and the request gets blocked.
While i paste the url in browser it return the response correctly.

When i change the url of the endpoint to the request doesn’t get blocked by brave.
Also i tried to remove all the headers being sent and still no success.
But with other Browsers it works fine. So I think it is a Brave issue.

Exact URL of the website in question: is the subdomain
Did the issue present with default Shields settings? (yes/no)
Does the site function as expected when Shields are turned off?
Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no):
No it’s the default configuration of brave (just downloaded it).

Does the site work as expected when using Chrome?
Brave version (check About Brave):


1 Like

Hello @jurgen333

go to your site when click on the lion icon on the right of the address bar then go to advanced view then change the cookies to allow all and see if it help or not and have a nice day :slight_smile:

1 Like

it doesn’t work !These are the response headers and in the lion icon i see that my endpoint is blocked for cross-site trackers.

I am testing it from localhost

did you tried to change the setting of the shield like allow all tracker or allow all fingerprint or both

i shouldn’t be asking the end users to do that, it should work with default configuration of Brave because i am not tracking any analytics or displaying ads.

click on the shield icon then check what it on the tracker sections block also check in the console what it blocked

maybe the other server insert some code

that why i asked you to disable the shield so to make sure that the issue come from the shield and nothing else

you need to troubleshoot the issue then know the cause then fix it
i never said that you tell user to do that but to troubleshoot

another question is that internal domain or there a link so to check it or it under development or what?

hope that help and have a nice day :slight_smile:

could you check @fanboynz that

and have a nice day :slight_smile:

#1 When i switch the shield off, the request doesn’t get blocked anymore.

#2 This is a test url that you can try, when accessing it directly in Brave browser url the request doesn’t get blocked, while using it inside a react app without adding anything else to the request it gets blocked.

Thanks in advance.

thanks for you but the link does not work it just bring the status code 200 and while shield on or off and same thing in firefox

let me as one of the team @fanboynz if he could help you

and have a nice day both of you :slight_smile:

the link works its a test endpoint it will return you status code and a random number in body, as i said try it inside a react app and send a get request to that url

What’s the ful url being blocked? Can it be produced by myself? @jurgen333

you can replicate the issue => create react app and do a fetch request like this

  .then(response => console.log(response.json()))

if that the case then it work fine here even on aggresive setting

is that random? i mean does the issue show up and vanish in random way?

could you also try to create new profile and check it work there fine

also try to clear the history of the shield setting

hope one of those help and have a nice day :slight_smile:

you are not getting the point try to send that request from a web app because when i do this request from a react app brave blocks it, hopefully @fanboynz got the point.
It’s not random every time i send a request to that url that you used there from a react app it gets blocked.
This has nothing to do with shield settings i haven’t changed anything i just downloaded brave.

If you install uBlock Origin, does the same item show as blocked? Do you have lists enabled in brave://adblock ?

#1 Yes the same results, and i have uBlock Origin in Chrome installed aswell but the request its not blocked there just on brave

#2 All checkboxes are empty

Hi, I’ve made an adjustment to the filters. give it 24-48hrs


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.