Brave blocking exe download

windows
bug

#1

Description of the issue: I was trying to download a program and Brave blocked the exe from downloading. It didn’t give me an option to approve it or otherwise tell me how to unblock the download. I turned off the shields and the file still got blocked. I couldn’t find anything in the Settings that seemed to control blocking downloads.

Steps to Reproduce (add as many as necessary): I was trying to download the Kobo Books eReader app for Windows Desktop from the Kobo website. I clicked the Download Now button and then chose where to save the file. The download bar appeared on the bottom of the screen but it had a red icon and said the download was blocked by Brave.

Actual Result (gifs and screenshots are welcome!): The download bar appeared on the bottom of the screen but it had a red icon and said the download was blocked by Brave.

Expected result: I expected Brave to download the file or at least tell me how to unblock the file so it would download.

Reproduces how often: So far just that website but I haven’t needed to download any other programs recently.

Brave Version(about:brave): Version 0.57.18 Chromium: 71.0.3578.80 (Official Build) (64-bit)

Reproducible on current live release (yes/no): yes, my browser is up to date as of today.


#2

@kitttenthatmoos, excelent reporting! Appreciate all the detail.
We’re actually looking into ths ourselves right now and this information is very valuable.
It’s very likely that the issue stems from a chromium update in which the “safe browsing” mode gets a little ahead of itself.

I’ll reply back when I have more information.
Thank you again!


#3

Actually, @kitttenthatmoos,
If you (or anyone encountering this issue) wouldn’t mind, can you confirm for me whether or not it only blocks .exe files or if it’s blocking other file types from being downloaded as well.
Thanks!


#4

I did some tests and it looks like the exe I was trying to download works now. It also downloaded a zip file and a PDF just fine. I’m not sure why it wasn’t working last week.


#5

It seems as though the Chromium framework had some updates to the “Safe Browsing” feature that was catching a lot of package or executable downloads. We pushed an update over the weekend that may have resolved the issue by default.

We’d still like to keep an eye out on this stuff so please let us know if you experience this again.
Also, thank you for updating in general - really appreciate the feedback and troubleshooting on your end.