Brave Beta Bookmark Sync Issues Across Different OS'

So the issue I’m facing is that Sync isn’t working properly across various desktops and my Android phone. I have Brave on two different Windows OS’, two different Linux distributions, and my Android phone. I changed around some Bookmarks and added a folder and bookmark on my Windows Brave Beta. I then waited an additional 24 hours with repeated usage on all OS’ and mobile to allow time for the bookmarks to sync. They have still not synced at this point, and it’s been 48+ hours. On one of my Linux distros, it duplicated all my bookmarks to where I had to go and manually delete the duplicates. So there are some issues happening with sync and I can’t figure out what the issue is. I ensured all were set to “Sync Everything”, changed it to manual sync and all toggles were on, uninstalled, deleted the config file, reinstalled, resynced, and still not getting the correct bookmarks. All Brave Beta’s are up to date as well.

  1. Change bookmarks and add bookmarks on Brave Beta browser (Windows)
  2. Ensure Brave Beta is synced on Linux OS’ and Android mobile phone.
  3. See that Bookmark syncs are not working on either Linux (Pop!_OS .deb Brave, and Garuda Linux (Arch Linux based)). Android is a Pixel 6a

Consistently. Have used Browsers constantly over past 48 hours and bookmarks not syncing.

Brave is up to date

Version 1.63.138 Chromium: 121.0.6167.85 (Official Build) beta (64-bit)

Windows 11 (2 different devices), Pop!_OS (.deb Linux), Garuda Linux (Arch Linux), Pixel 6a (Android 14)

I have also searched the forum and haven’t come across anything from this year or anything pertinent from last year either.