Brave 1.67 requires IOS > 16

Brave is one of the best browsers I have ever used.
So it’s certainly understandable that I was very disappointed when I found out that from version 1.67 onwards, installation is only supported on IOS greater than 16.
Is this limitation really (technically) necessary or can it be reversed?

iPhone 6s
IOS 15.8.2

EDIT
Corrected typo
/EDIT

1 Like

Please, I also need brave on ios 15