State of Linux support

I use Brave on my Windows and Android, it is currently the best browser available in my opinion.
When I use it on Linux it is another story, there are many problems making it unusable:

  • Scrolling in Wayland is not obeying scroll speed from the system settings, it is too slow to use
  • No middle mouse button auto-scroll
  • No pinch zoom on touch pad
  • System Dark Mode suddenly stopped working in websites, I am able to toggle the prefers-color-scheme from the developer options and it works but that’s not a solution as it goes back to light mode when I reopen the web page.
  • After a while I see high CPU usage, not sure what’s causing it and it appears to be random after a few minutes or hours of using the browser.

I am sure I missed out some more problems and I am aware some of these issues are in chromium itself but given that the browser’s target users are privacy conscious I am assuming many of us are using Linux even if its a dual boot with Windows.

Is there a reason why these problems have not been fixed since I tested them last year? I am currently forced to use another non-chromium browser on Linux because of these issues.

2 Likes

I guess the reason is the same as what troubles most companies are facing nowadays. The lack of real experts in Unix based systems. This is a problem for most companies. Unix engineers are few and expensive.
On top of that, the amount of different Linux distributions does not make it easy. It is difficult to be compatible with all of them.

1 Like

I am using Brave’s Desktop browser on my Chromebook/Linux and it is a very smooth experience here.

I am sorry to hear of your problems on your Linux installation.

1 Like

@treego14 Would you please explain which of my points work for you? and are you using ChromeOS or a real Linux distro?

@rodrige I don’t think that’s true, since the other browser - that I am not going to mention - is also working well on Linux with none of the above mentioned issues.

Brave already has the chromium engine built by google and the open source community while the other browser does that in addition to making sure everything is working well on Linux.

I am using ChromeOS.

Have you set Preferred Ozone platform to Auto in brave://flags? That allows the browser to render natively with Wayland instead of going through XWayland and it fixes things like pinch zoom on the touch pad for me. Not sure about the other issues you’re experiencing, but worth trying out.

@urbenlegend Yes I have and I also tried directly setting it to Wayland but from what I read online this problem has been in chromium since 2015 and still is.

So I did a bit more digging and testing on my Arch Linux box running Gnome Wayland.

  1. Scrolling speed seems fine for me in Gnome Wayland. Perhaps its DE specific?
  2. Middle click auto-scroll is apparently disabled on Chromium for Linux/Mac, but there is an experimental flag you can enable. See here: https://askubuntu.com/a/1419189
  3. Can’t reproduce on my end. Pinch zoom works flawlessly here. Again, I wonder if its a DE specific issue. Or maybe something weird with your trackpad drivers.
  4. How are you triggering dark mode? Dark mode integration for all apps, not just Chromium has long been a sticky point with Linux.
  5. Is that high CPU usage associated with a Brave process? If so, you can go to Brave Menu → More tools → Task Manager and see exactly which tab is causing the high CPU usage.

Thank you for your help.

1- The scrolling speed does not work on kde and on gnome, I tested on 2 different machines, did you try to increase the speed from settings? maybe you are used to slow speeds that’s why you didn’t notice it, this bug is in all chromium browsers including electron apps. Only VSCode fixed it by adding an overwrite setting to adjust the number of lines you scroll.
2- This actually helps a lot, but it shows a warning on startup, not a big issue.
3- It suddenly started working now after enabling blink flag.
4- It was working fine when I installed Brave, it stopped working without anything done from my side. the dark mode is activated on the whole system and every app obeys it, also dark theme is selected in brave just in case. still no luck.
5- Yes, it is a high CPU spike and nothing fixed it except restarting brave, I have a feeling it has to do with extensions so I am disabling them and so far its ok.

This is really weird, i’m on Linux Mint and Brave for me it is the best browser on my system

1 Like

I’m experiencing several problems with Brave Wallet on Linux. I’ve reported them on github and still nothing. Sadly, after a couple of months I’ve decide to use again Metamask.
I use Brave Wallet both on Windows and Android, none of them shows the same issues found on Linux. Just to add a problem to the list described in the initial post.

Actually, how are you changing your scrolling speed settings? Gnome 43 doesn’t seem like it exposes those settings for some reason.

Can you link your github issues for me to take a look over?

(I am not affiliated with brave team, just wanted to look into it.)

The main issue is this which is 100% related to the brave wallet. Sadly, no steps to reproduce it exactly.
Initially there was an issue that was “fixed” but with no commit associated with it. This was the start of the problems with Linux.

I too have Linux Mint and Brave but Rumble videos will not play[quote=“UltraViolet, post:11, topic:435232, full:true”]
This is really weird, i’m on Linux Mint and Brave for me it is the best I d

just tried Rumble; first video i tried with shields set to aggressive and fingerprinting set to strict and block video autoplay on [or off] worked perfectly
have you changed any settings?

Hi,
fyi, using brave on openSuSE (DE) having none of these problems.

1 Like

Quick update to anyone having problems with scoll speed or pinch zoom I found that you need to set #ozone-platform-hint to auto or Wayland in order for it to respect the scroll speed.

And the dark mode problem is actually caused by “Block fingerprinting” in shields to “strict” it is working correctly after changing it to “standard” and sites are able to detect my system color. However, this was working with the strict mode on windows and android so I am not sure why this happens in linux.