Bluetooth Audio Not Working

Description of the issue: Brave doesn’t play audio through any device connected to Bluetooth

How can this issue be reproduced?
My laptop is an MSI GF-63 running the latest version of Windows 11. Brave doesn’t play audio through my Nothing ear(stick) connected thought Bluetooth. Audio is working fine for other apps like Netflix, Edge, Spotify, etc. I thought it was an issue on my earphones and tried connecting it to Brave on my mobile. It was working properly. I even tried connecting my roommate’s Bluetooth earphone and it still doesn’t work.

Expected result: Audio to play through Bluetooth connected device

Brave Version: Version 1.48.158 Chromium: 110.0.5481.77 (Official Build) (64-bit)

Could you try in a private window?
If that works, it is probably some extension interfering.
You should try removing extensions one by one to see which one is causing this.

There is no change in private windows either. I haven’t added any new extensions in a while and this issue happened since an update 2-3 versions ago was released. I kept on waiting hoping that it would be fixed in the next update, but nothing has happened.

@Saoiray @rodrige do you guys have any idea?

Any way to fix this?

@Saoiray @Aman_M @rodrige any ideas ?
@Mattches coud you take a look too ? Thanks so much!

1 Like

Bluetooth is a system configuation, not a browser setting

  • Just check that volume is enabled globally and per-app (Brave in this case)
  • Ensure that the correct headphones are defaulted in WIndows.
  • Check the browser tab isn’t muted
  • Re-pair the headphones, then check bluetooth settings (above).

I tried all of this using both mine and my roommate’s Bluetooth earphones. I had also seen quite a few similar posts saying audio isn’t working for Bluetooth devices. Is it by any chance something that happened while pushing a new fix?

Reason I took so long to reply was to check using another device as well.

Can you tell me what sites you’re testing the sound on in Brave? Also can you please update to the latest build (v1.48.167) and ensure that this doesn’t fix the issue by itself?

Brave is updated to the build you’ve mentioned and it still hasn’t changed.

These are the sites I’ve tried testing it on:

I’ve also tried attending meetings via Google Meet on Brave as well. The microphone is working, but outgoing audio isn’t.

Same issue here. Chrome works fine, it’s just brave which plays all audio through speakers. Currently unusable in office, so going to have to switch to chrome.

Other than mute tabs or a site, Brave has no control over bluetooth audio. Check the hightlighted in the screenshot. Testing

Here’s a fix for this. I was also facing the same issue with the Brave browser particularly. Everything else was working fine with the Bluetooth. What I did was, I disabled my in-built speaker through the manage sound devices in the sound settings and the only option for the audio left was Bluetooth. Then I tried using Brave browser and it was working fine

It doesn’t seem related to bluetooth, more that Brave ignores the set output device and reverts to system default. This is on mac and other browsers are working correctly.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.