Anoying Ads on Twitch

Annoying Ads on Twitch streams for Geico and sometimes Coca Cola

Website: .Sometimes when i click on the ad it direct me to this website: .Brave tells me that the domain is blocked when i click Proceed button send me to this:


“Did the issue present with default Shields settings? (yes/no)”
Im not sure about this, sometimes Twitch video ads dont play for weeks and sometimes its in every stream i click

Does the site function as expected when Shields are turned off? Yes

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no): im not sure

Does the site work as expected when using Chrome? yes

Brave version (check About Brave):
Version 1.52.122 Chromium: 114.0.5735.110 (Official Build) (64-bit)

There is not much to do in Brave with Shields.
Amazon is embedding the ads, which means no adblocker will work.

The only thing working at the moment is using Proxies, which can be insecure because you have no idea where they are placed, but they point to a region where ads haven’t been implemented so you don’t see ads.

uBlock, Adguard, tampermonkey and other adblockers let you load scriptlets or userscripts in the case of Tampermonkey.
But they turn ineffective from time to time, of pretty often, few days ago they updated them, and it seems to work okayish? most of the time?

You can get extensions and the scriptlets and userscripts here:

I said you can’t do it in Brave shields, but that’s not totally true, just officially, because it’s not about Brave not being able to do it, but because it doesn’t have a feature to load scriptlets officially, they will add it someday, but who knows when, they opened the issue and it was opened by one of the devs, so hope he can add it soonish, at least this year.

I said ‘officially’, because I did my detective work and could add the scriptlets myself, but it is not as simple as just adding a line and done, that’s why I said the scriptlets work in Brave but can’t be sideloaded unless you do some small tricks and understand how it works, then you have to maintain it because every update on the resources will wipe it.
So it can be done, but better use official alternatives, which you will not have to do much and you just load the file and done.

If you want to test it, I made the file for you to just replace (if you want to reset file, just delete it and restart Brave, it will be re-downloaded).

resources.json (link should be valid for a while)

And you replace the file in %localappdata%\BraveSoftware\Brave-Browser\User Data\mfddibmblmbccpadfndgakiopmmhebop\1.0.40\

restart Brave, go to Brave://adblock and add either


test what works better for you. Save it and done.

You can’t enable both at the same time, so test one at a time.

But that’s how you hack it to Brave without waiting for Brave team to implement to sideload our own scriptlets.


You can compare original and my modified resources.json file, all I added was the two scriptlets so if you don’t call them (don’t trust them) then they will not work, Brave Scriptlets don’t work generically like UserScripts can, only with specific rules.


you can open console and check the scriptlet is working because you will see, Twitch adblocker is enabled in the Info filter.
Also you should see a “Blocking ads” when the video starts on top of the video, the scriptlet will change resolutions and all that, so be aware of that.
I am currently using VAFT but when using the other one, was working also okay.

Both scriptlets still having the “Full screen ad message displayed during ads” is that preferable over just watching ads?

In my case I only see the “Blocking ads” and the resolution going to 360p and then you can see it switching to Auto (most of the time).

But maybe on other zones the ads are more aggressive and I am lucky? I know I get ads because when I don’t use the scriptlets I see ads, and yesterday I got like 0.5ms of an xbox ad that was blocked immediately.

Before the latest update few days ago, I used to see the “preparing stream” and the “currently ads purple screen sometimes”, my trick in the middle of a stream was to stop the stream and click play and eventually it would skip the ads, but I don’t see the screen either, everything is nicer.

But nah, honestly, I would poke my eyes with a cactus and put my hands on acid while pulling out my nails than watching ads, maybe if they were silent ads but no, they are not, always the most annoying BS ads with dumb voices or effect sounds.

Amazon and Twitch have made it difficult more and more to block their garbage, and I will never support that even if I have to stop the stream and wait for the ads to end.

@fanboynz This is my experience with these scriptlets.

As you can see I get ads as soon as I turn Shields off, because the custom filter is not in place anymore.

Disabling shields completely vs not having that rule enabled, might show different results.

nah, not really, even if I block most useless scripts and only allow the essentials and I use cosmetics everywhere, even use :has() to emulate Unwanted Twitch extension, and remove all badges and mod twitch in every possible way, it doesn’t change if I just disable shields or the rule for these ads:

The good thing is Brave works great with uBlock scriptlets, that’s why I don’t need uBlock on twitch and many other websites even if I need to build some workarounds about some features, especially when it comes to cosmetics, well just hacking the scriptlets into Brave is a workaround itself until official support.
Using the scriptlets just make the loading of channels slower, but it works.

Which of the 2 snippets is more useful? The lest disruptive to the user


I am using VAFT, that’s in my case.

the problem with video-swap-new is that it needs and update, so unless you are on Auto quality, it will go to 360p and stay in 360p until you manually switch quality. if you had selected 480p+, the script will not switch to it because when it block the ads, it will not show any other quality but 360p.

Someone reported it but who knows when it will get fixed.

In Auto, when the ads are over and the qualities 480p+ come back, then the stream stops just a tiny 0.1ms and gets the whatever high quality Auto decides to give, noticeable stop but not big deal.

so, VAFT not having a bug like that is nicer right now for me. VAFT stays few seconds in 360p and then bumps the quality in number, so when the ads finish = stops being 360p stream, then it seamlessly switches to the preferred quality without the weird little stop video-swap-new does. BUT it might be about the bug, so VAFT wins because of the bug.

But honestly, can’t really see any difference in the way they block ads, besides seeing some drop in quality from time to time and the “Blocking ads” message, video-swap-new says Blocking midroll ads as well, but they seem to do the same thing without really noticeable difference, just the quality switch seems nicer in VAFT, so, whatever the method, seems to have reached a similar point, to lower the quality when the ads are going on.

I was using video-swap-new, but for the bug has been using VAFT for like a week and only saw 0.5ms of an XBOX ad that got quickly blocked. I still keep both and should update the other one when fixed.

Seems like scriptlets’ update made things better or whatever Twitch changed that needed those fixes, it was a really weird experience sometimes when it blocked ads but not anymore. Maybe Twitch changes backfired.

But my experience and my region might differ from other people’s experience, but I tested in TOR and ads weren’t present there either and TOR always takes me to some EU country.

Edit: reworded some stuff to make it clearer and noticed the Blocking midroll ads wording when video-swap-new testing it.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.