Android brave keeps stopping

Troubleshooting technical issues is much easier when both the user and support agent practice clear communication. For this reason, we have provided the template below for you to fill out with information about your issue. Please provide as much detail as possible so we can most efficiently resolve your problem.

Description of the issue:
Whenever I try to open brave browser, it crashes. Android shows “brave keeps stopping”.

How can this issue be reproduced?

  1. open brave browser

Expected result:
not crashing

Brave Version( check About Brave):

Mobile Device details
Nexus 5 on Android 9 (PixelExperience_hammerhead-9.0-20200221)

Additional Information:
I already tried clearing cache and rebooting phone.
I sent a feedback in case that helps…


Is this a custom rom?
Nexus 5 on Android 9 (PixelExperience_hammerhead-9.0-20200221)


You probably rooted your phone or just installed a android 9 pie ROM that isn’t quite compatible with your device. Nexus 5 Normally has android 5 lollipop This is a huge difference and your OS may not be configured right. It’s hard to explain since my lack of knowledge.


Yes it is a custom rom. However I installed it a few months ago, and I didn’t have any problem with brave browser until a few days ago. So I’m pretty sure it’s not related.

1 Like

Well I can’t do much sorry. maybe try to install a older version via internet? that is all i can do I’m so sorry.

1 Like

I have the exact same problem when it did not happen before. Crashes upon opening for no reason. I’m using a stock galaxy s20 ultra on android 10, one ui 2.5

1 Like

Damn That is One brand new model. I will look into it. didn’t expect this.

1 Like

So I assume you guys have plenty of storage left so that can’t be the problem here.
Maybe too many apps that cause memory overuse/low amount of ram(memory) check some apps on play store to check your ram.
Maybe a dumb question but did you restart your device?
Clear app data and cache.
Kill the app.
wait till app update.

P.S. to DarkmanXTC.
It Seems that galaxy s20 has it’s own problem like app crashing Most likely facebook. so maybe wait till s20 software update.

1 Like

Again to DarkmanXTC Try this

To both of you This is far beyond my knowledge and I try to Think of everything I know. I hope someone that does know more about situation joins us and help.


Looks like the update (5hrs ago) fixed the issue.

PS @ThijsL202 : Please do not tell people to reinstall the app because they will lose their accumulated BAT. Same thing goes for clearing app data.
Also, you should read OP before giving advices ( “I already tried clearing cache and rebooting phone.”). Thanks anyway for your time spent.

1 Like

ohh sorry I totaly forgot that I will edit the commands so noone will ever try it.

1 Like

Before you read the whole post, go to the end and see what solved it for me… The details are for the devs.

I have something similar. Brave freezes a few seconds after launch. It is disables the keyboard (hackers keyboard), does not respond to taps, disables soft navigation (back, open apps, home), locking screen with power button works, but unlocking results in a white screen without status bar or navigation keys.

Soon after the blank White screen, a dialog appears, ‘app has stopped responding’, with options to close, wait or report. Wait sometimes restores touchscreen control for a few seconds.

Going fast permits time to direct Brave to a URL, which always results in a page that says, "We’re sorry, Brave is having trouble showing this page. If this happens often, try these solutions.

The word ‘solutions’ is a link, but at that point Brave is unresposive. So I can’t follow it. This page appears for every URL tried.

I believe this bug is caused by website scripting designed to discourage users who may employ one or more of the following:
ad blocking, script blocking, location masking, VPN IP anonymizers, content-protection workarounds, clipboard hot-linking, manual URL editing, mapping-spiders, strong defensive techniques; redering them a waste of bandwidth, because they’re worthless to site owners.

Firefox gets around the problem by presenting the desired information in a correct format but altered content. However, in the last few years Mozilla has bowed to the web-commercialization gods, and added anti-features and objects that give webmasters greater control.

But since the problem does not correspond to a Brave app update, but rather to location spoofing for geo-restricted sites; it reeks of an app exploit!

I used Brave for that. The problem began about that time. I’ve used AVG SCANNER, deep scan, which found nothing. My plan is to wait for the next update, because removing and reinstalling might remove all data.

Device: Samsung Galaxy Tab S4 SM-T835 Factory Unlocked tablet, Android 10, latest security patch.

Brave latest version (no update available).

Solutions tried
Forced stop of Brave.
Cleared Brave Cache, but not Data.
Tried again.
Same problem.
Booted to recovery mode.
Wiped cache partition.
Tried again.
Same problem.
Hibernated all possible apps.
Same problem.
Optimized memory in Settings > ‘Device Care’.
Same problem.
Same problem.

Brave is not usable. My expectation is self-evident.

Edit, I sub

I tried Seetings>Brave>Storage>Manage Data
Tablet went black. No life signs but a tiny orange (.5mm?) Dot in the upper right corner.
Locked display with power button and unlocked. Manage data screen was displayed but frozen.
Same problems as before.
Tried Developer Options>Reset to Defaults>Toggled off for developer options.
I only set the developer options to default settings, not the entire operating system. Then, I turned off developer options, which makes the option vanish from Settings.
Brave was then operational again, all data intact.

This suggest the browser’s stored data, which contains ‘resume session’ data, open tabs, history, bookmarks, passwords, and the ‘last state info’ may get contaminated in some connected to activated developer options.

However, I have not the time or will to nail this one down.

But the nature of the malfunction and its context, in my case, suggest it is not a random bug.

Edit, Within developer options, I had activated to force install to external storage (SDcard) option. I had moved Brave from Internal to external storage, using Settings>Apps>Brave Browser>Change Storage Media.

Option is only available if activated in developer options. I forgot I had moved Brave back to internal storage before it suddenly worked again.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.