Android Autofill API enabled in Brave?

Is the Android Autofill API enabled in Brave? I use Bitwarden to manage passwords, and it works great for most apps on my phone, but when trying to fill in website passwords in Brave I have to revert to the less graceful Accessibility option. Apparently if the Autofill API was enabled this wouldn’t be necessary.



I have the same problem.

In my most recent update to Brave this is even less reliable. Now when I select a password field I see an unexplained new UI for entering passwords above the keyboard and Bitwarden’s auto fill menu never appears. I don’t want to use brave to store passwords since I use a password manager that integrates with other apps.

1 Like

Yea it’s been 2 years since Android introduced the auto fill API (Oreo 8.1) now that we’re on Android 10 there’s no excuse anymore to not fix this. It’s definitely a deal breaker for me. I’ll have to go back to Firefox, it’s too bad I liked brave a lot but a browser that doesn’t play nice with password managers in 2019 is like shipping a smart phone with only a T9 keyboard and assuming that’s fine because it’s going to be used mostly as a phone. I guess the people at brave use just the simple password for everything

Brave should enhance this.

Same here. I use the password manager Enpass and it can’t figure out what site it’s trying to fill.

An update on the current situation on my phone.

Android 9 (pie) on Motorola One, August security updates applied
Brave version: 1.3.2, Chromium 76.0.3809.132
Chrome version: 77.0.3865.73

Password manager: Bitwarden version 2.2.2 (2072)

Experience in Brave: Using the login page I sometimes get the Bitwarden pop up when I put the cursor into a login field. While writing this, I tested and logged in successfully. However, I then logged out and tried again, and the pop-up no longer appeared.

Experience in Chrome: The same.

Closing Brave and Chrome from the Android app switcher, then starting them again seems to revive the pop-up but just for the first time. Subsequent attempts to login have the same experience.

So it looks to me that Brave might indeed have the API enabled, but something else is preventing the pop-up.

If you are having similar challenges with another password manager, it would be great to hear more.

Just found a bug report around this for Android:

That is specifically for lastpass but I wonder if it applies to anything using the Autofill service.

Apparently fixed in Android 10 - not sure when I’ll be able to test that :frowning:

It’s not fixed in Android 10 still have to use the accessibility workaround.
Besides you can’t just fix it for Android 10 and not 8 & 9 because it’s it’s The same API

The best way to see if the API is enabled it’s go to any login text block and hold down so you get the “paste” option there sold be three vertical does at the end if you cock that it will give you an auto fill option. If those doors are there the API is in use

I updated my phone to Android 10 and now works better.

When you get to a login screen is there the little squircle that says login to LastPass and then after had your information or is it the larger rectangular box that says Autofill on the top (maybe with a ‘+’ )?

I select the rectangle and show a option “AutoFill” (BitWarden).

That’s not the Autofill API that’s just the older accessibility option. :frowning:

Still getting this with November Security updates to Android 9 - waiting on 10 arriving on the Motorola One or updates to Chromium.

Still waiting on this :frowning:

I’ve had another go at this since getting the December 2019 security update for Android 9 on my Motorola One.

I noticed that I had not changed the Battery Optimisation settings for Bitwarden, which may mean the issue was user error rather than any change that arose through updates. I changed this to Not Optimised like this:

Settings > Apps & Notifications > View all apps > Bitwarden > Advanced > Battery > Battery Optimization > All Apps > Bitwarden > Select Don’t optimize.

After doing this, I disabled both the Autofill and Accessibility services for Bitwarden as folllows:

Settings > Accessibility > Bitwarden > Toggle off
Settings > Languages & input > Advanced > Autofill Service > Select None

I then toggled Autofill back on to Bitwarden.

My test is to go to’s sign in page (sign out if necessary). The autofill pop-up now appears. Great!

If you are using another Password manager, please try the battery optimization trick and share here.

1 Like

It’s interesting to see how Brave ignores this important feature.

What’s even more interesting is how Chrome has this feature and Brave, which is derived from Chromium, doesn’t.

I’m quite unhappy about the situation, especially given the fact that we have autofill API in Android since two years now.

I’m considering going back to Chrome actually

1 Like

I can confirm this issue still exists in Android 10.

Relevant google docs:

@steeven can you take a look at this one?