AutoFill not working reliably with Bitwarden or Keepass2Android

Description of the issue:
I was testing out Bitwarden and KeePass AutoFill functionality in the Brave mobile browser. I just cannot seem to get it to work consistently for either of them. For Keepass, I have KeePass2Android (with kp2a.plugin.AutoFill-1.02.apk plugin).

Steps to Reproduce (add as many as necessary):

  1. Install latest Brave mobile browser on Android
  2. Install Keepass2Android and kp2a.plugin.AutoFill-1.02.apk plugin. Turn on AutoFill service in Android settings and in the app. Alternatively, install Bitwarden and turn on both AutoFill services.
  3. Try to auto-fill username and password on a website
  4. Auto-fill does not populate

Actual Result (gifs and screenshots are welcome!):
Auto-Fill fields do not auto-fill

Expected result:
The fields should auto-fill

Reproduces how often:
Most of the time

Brave Version(See the About Brave page in Settings):
Brave 1.1.0, Chromium 75.0.3770.101

Mobile Device details
Samsung Galaxy Tab S3

Android/iOS Version
Android 8.0.0

Additional Information:

Hi @XDptguOE, welcome to community! Thanks for posting your issue here.

@Mattches, would you mind testing this?

I will also add that the AutoFill functionality works fine in Firefox. Also, on my PC I was able to get it to work in Brave (via the normal KeePass ctrl+alt+a keyboard shortcut) by adding the command “–force-renderer-accessibility” when opening Brave.

This issue also affects Enpass autofill.

im having same problem with bitwarden on android. really is a deal breaker for me. not going to copy and paste all the time. will it be fixed? thanks

For me (android pie), autofill with keepass2android works 100% of a time. I haven’t tested it too much as I only started using it yesterday, but haven’t found any problems. If anything, I had more problems on desktop version as every webpage is unique and it wouldn’t recognise username and password fields on some of them.

I think it could work for me but it seems to want to search for entries related to “androidapp://com.brave.browser”. In fact, I just added that URL to an entry and autofill worked. However that’s obviously not going to be a solution. It works in Firefox without that. The issue seems to be that KeePass is not getting the URL from Brave (like it does via the share function). Also if I manually preselect the entry beforehand, it will autofill.

(By the way, to get this far, I had to have KeePass2Android and kp2a.plugin.AutoFill-1.02.apk installed. Then in settings under “system, languages and input, autofill service” turn on KeePass2Android. Then under accessibility make sure KP2A AutoFill Service is enabled. Then in the KP2A app, under settings go to plug ins and make sure the autofill service is enabled. Also in KP2A app settings go to Password Entry Access and Autofill Service and make sure it’s enabled and you don’t have any disabled targets.)

OOOOhhh… I did not know that firefox does it the correct way. I just assumed Brave’s way is the right one (as I said, this is the second day of me using KeePass2Android). Then yeah. It doesn’t work for me as well.

@Mattches would you mind taking a look at this when you have a moment.

Thanks @steeven.
I’d like to note that extensions/3rd party apps are currently not officially supported in Brave. We are, however, looking at allowing this functionality down the line:

Does this really require much integration on the part of Brave? It works in Firefox without any add-on or extension.
Additionally, this ability is a must-have for your entire user base (although all users may not know it). Nowadays a password manager is really a requirement–not a feature. As a browser that is supposedly focused on privacy and security, Brave should ensure compatibility of password managers as a core component. Not ensuring this seems hypocritical at the least. It’s like saying you created the safest vehicle on the road, but it doesn’t have seat belts.

@XDptguOE,
That’s an excellent point.
After taking your point and doing some further testing, I was able to get both Keepass2 and BitWarden enabled and working with Brave on my Galaxy S9+ – and without any additional finagling.

So for anyone who is still encountering this issue (there seem to be quite a few people involved in this thread), can you please tell me which app you’re having issues with and what the exact behavior is?

Well that was fast. So you are able to open Brave, load a website like Bank of America maybe, and without any additional action (not clicking Share or something from the top bar of Android or switching keyboards) it will automatically populate both the username and password field?

@XDptguOE,
I have it set to not auto populate, but if I click in the form field, the Bitwarden context menu appears with any relevant passwords/logins available.

Can you tell me what you see on your end when you try this?

1 Like

@Mattches
I re-enabled the Bitwarden auto-fill service and auto-fill accessibility service and it seems to work fine now for a few websites I try :neutral_face:. However I really prefer KeePass and that one doesn’t work. I click on a field and get nothing. In the swipe down menu from above there’s an item to auto fill from KP2A, but when I click it it seems it’s searching for “androidapp//:…” and not the URL.

@XDptguOE,
Let me dig into this a bit tonight – ping me tomorrow if I haven’t gotten back to you.

Have you had time to look into this more?

Hello

I have a Huawei P30 PRo and I am facing to the same issue as described by @XDptguOE. I followed his explanation about installing the plugin and so on. Now I have a Keepass2Android notification for “androidapp://com.brave.browser” entry. I can fill username/password manually by selecting another entry but it should be a temporary solution.
@Mattches did you have time to look into this issue ?

It’s as if the app is pulling the app name instead of website URL. This makes it always search the KP2A database for the Brave browser as an entry, which is not useful. I assume it’s an issue with Brave since it works in other browsers, but I don’t know enough to be sure.

This topic was automatically closed after 30 days. New replies are no longer allowed.