Amazon On Brave is using Way too much CPU/Battery

Recently when I was browsing furniture on amazon.com my computer’s fan started going crazy and Brave’s energy impact shot up to 250-350 and stayed there until I closed the tab. Of course this means that Braves CPU usage shoot through the roof, under a “amazon rendering helper” category. This has happened before but I never paid it too much attention, but this time it with a rather important site to use and I would like to know how to keep this from happening. Thanks

Switch to Aggressive mode in shields, does that help? @lightning17

@lightning17

Go to: brave://settings/content/javascript

Scroll down to: Allowed to use javascript

Add:

  • [*.]amazon.com:443

Try to disable the influence of the website, via the following steps (they are, ‘sort of generic’ for a variety of issues) . . .

This section - because it allows Brave Browser to start up without a burden:

In a Brave Browser > New Window, go to: brave://settings/getStarted

  • Select: Open a specific page or set of pages
  • Select: Add a new page
  • Enter: about:blank (notice the colon)

This section - to clear away cache and cookies:

Go to: brave://settings/clearBrowserData

For tab Basic - set:

  • Time range:All time
  • Enable: Browsing history
  • Enable: Cookies and other site data (Signs you out of most sites)
  • Enable: Cached images and files

Click on the “Clear data” button.

(The “Clear data” button also saves the selections.)

This section - because Google things:

Go to: brave://settings/shields

  • Disable: Auto-redirect AMP pages

If you have an older version of Brave Browser, try:

  • Disable Enable De-AMP at brave://flags

This section in order to keep control in your court:

Go to: brave://settings/content

Scroll down to “Additional permissions” . . . and set:

  • Protocol handlers: Don't allow sites to handle protocols
  • File editing: Don't allow sites to edit files or folders on your device
  • Clipboard: Don't allow sites to see text or images on your clipboard
  • Window placement: Don't allow sites use info about your screens to open and place windows

Scroll down to “Content” . . . and set:

  • Pop-ups and redirects: Don't allow sites to send pop-ups or use redirects

Do you have one or more:

  • anti-virus extensions
  • Internet security extensions

. . . installed?

Nope, amazon still runs up my cpu usage for “Brave Browser helper (Renderer)” and my battery energy usage goes through the roof.

I tried the javascript method and it didn’t help. All my other blocker extensions are deactivated.

Not sure if its fixable here, not a “Brave issue” from what I see. Tested Brave Sheilds (Aggressive) and Brave + UBO (Shields disabled). There is probably some tracking on the site that remains unblocked by shields and uBO, but the last thing we want is to accidently break amazon trying to counter this.

CPU usage would change when scrolling on a page as seen in the gifs. But the results between the 2 blockers is very similar. GPU acceleration would help here, disabling GPU acceleration would impact CPU, If the page is heavy on graphics and video would also impact perf.

Page tested: https://www.amazon.com/SteelSeries-Apex-RGB-Gaming-Keyboard/dp/B07ZGDPT4M/

Brave Sheilds (Aggressive): https://gif.fanboy.co.nz/gif/amazon-shields-agg.gif

Brave Shields (Disabled) + uBO: https://gif.fanboy.co.nz/gif/amazon-ubo.gif

I haven’t tested no ad blocker, but I suspect a bigger perf hit given the amount of trackers amazon loads.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.