All drop down menu's appear in top left corner

All of a sudden, whenever I click anything that produces a drop down menu (ie. the three bar icon in far right side, or a bookmarks bar folder), the drop down menu drops down from the very far left top corner of my screen. It used to drop down in place where the menu item was that I was clicking.

Here’s a screenshot of clicking the main menu button (ie. three line button in far right side):

**Brave Version( check About Brave): [Version 1.43.89 Chromium: 105.0.5195.102 (Official Build) (64-bit)]

Additional Information:
Fedora 36 (5.19.7-200.fc36.x86_64)
Gnome 42

Can anyone even confirm if they see this? Is it just me? Even tool-tips that popup when hovering images show up in the top left corner of screen. Typically it’s right by the cursor.

I really can’t help. I use win10 on desktop and this is not occurring on my system. I think some users were experiencing screen display issues a few months back but I couldn’t locate the topics and don’t really remember any details. Support staff are off for the weekend but maybe another community member will have more information and can help.

You might try:

  1. Playing with zoom and seeing if zooming in and out changes the behavior.
  2. Opening a new private window and seeing if the same thing happens.
  3. Disabling all extensions. An extension may be causing a problem.

Please post an update if you try any of the above. Take care.

Thanks for the tips. Unfortunately nothing has helped so far. It’s very strange.

Tagging @JimB1 a community member with way more technical knowledge.

Tagging @Mattches @Evan123 too. They are Brave support but since it is still the weekend, you probably won’t get a response until next week.

If your system set-up is a little different than normal, can you please provide details? Example, are you using dual monitors? display settings? I’m thinking this may be related to some system setting and it may help troubleshoot your issue. I am probably way off base on this one but more information can’t hurt!

Also, does this problem occur with other chromium based browsers or just Brave? You could also check if the problem is still occurring in the Beta and/or Nightly versions and post the results.

I found it.

Wayland Ozone as Default.


Also, Edge and others do it when set to Wayland Ozone as well.

1 Like

Official bug report:

Fixed in one of the Chromium 106 update versions. I think Brave should try and fast-track that fixed version.

1 Like

Nice find! Glad you at least know what is causing the problem even if there isn’t a permanent fix in place at this time.

According to the Release Schedule at Brave Github, Chromium 106 is scheduled for release in version 1.44.x on 09/27/2022. So hopefully will be fixed in a couple of weeks.

Take care. :slightly_smiling_face:


Great sleuthing here guys — super weird bug, glad the fix is already on the roadmap. Cheers!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.