[SOLVED]All Drop-down menus appear in the left corner only (Wayland)

Description of the issue:
After update to newest version of the browser all drop-down menus appear in the left corner only. I have tried reinstall, system reboot. It does not work. Never happened to me before. When performing system update today using apt update only the brave browser updated. nothing else.

How can this issue be reproduced?

  1. Have Ubuntu 22.10, Wayland desktop
  2. Update Brave to newest version (1.48.158)

Expected result:
All drop-down menus should appear at the proper location.

Brave Version: 1.48.158 Chromium: 110.0.5481.77 (Official Build) (64-bit)

Additional Information:

Thank you for any advises how to fix it.

1 Like

Hello there @Vasekos please accept my apologies for this inconvenience. Could you please try disabling your extensions to see if the issue persist?

  1. On your computer, open Brave.
  2. At the top right, click MenuMore toolsExtensions.
  3. On to the extension you want to remove, click Remove.
  4. Confirm by clicking Remove.

Let me know if that works.

Hello, no problem still persists. I have removed all extensions and restarted the browser but still same result.

1 Like

Same problem using Ubuntu 22.04 LTS (GNOME 42.5) release with the latest version of brave (still version: 1.48.158, Chromium: 110.0.5481.77)
When brave is using Wayland all drop-down menus are displayed in top left corner.
It wasn’t happening with older versions.

1 Like

hello @Vasekos

could you try the following :

  1. create new profile and see if it work fine or not (i do not think this will solve it but give it a try)

  2. could you create new linux user and start brave there with out changing any setting and see if it work fine or not?

hope one of those help and have a nice day :slight_smile:

Hi again @Vasekos, please try installing the Beta or Nightly version of Brave to see if the issue persists on those versions.

Be waiting.

Hello @justsomeone1
When I create a new linux user it works fine by default, because it’s using X11 instead of Wayland, but when I switch Ozone platform to Wayland to gain touch-pad gestures the problem is back.
Same result for new user profile in Brave.

Ok I will try it.
Today I updated browser to
Version 1.48.164 Chromium: 110.0.5481.100
but problem still persist since the 1.48.158 update.

Thank you for your tips.

1 Like

i use wayland also but on rocky linux(redhat derivative based on fedora)

and using gnome 40

by the way do you have dual monitor or is this behavior happen to any other app

not sure if that related or not


i know this is not for ubuntu but that the closet that i were able to get

hope it help and have a nice day :slight_smile:

@Vasekos does this same error repeats on other chromium based browsers such as chrome or Edge?

If it does, please let me know.

@Kevin_cc I don’t know, I’m only using Firefox and Brave as my browsers.
But I’m going to try it today and I will post all my gathered info.

1 Like

@Vasekos sure no worries. Please keep me updated if this issue persist on other browsers or if it only happens on Brave.

Be waiting for your response.

@Vasekos I’ve also been seeing this issue over the last weeks. It’s also happening in Chrome under Wayland, so sounds like a Chromium thing.

Version 1.48.164 Chromium: 110.0.5481.100 (Official Build) (64-bit)

I thought I saw this issue months ago, and then it got fixed, but is now back for me.


Sorry for a small pause.
Yes it’s a chromium problem. I have tried to install latest version of Google Chrome (Version 110.0.5481.100 (Official Build) (64-bit)) Also as @se7enZ mentioned.
And after enabling Wayland the problem it’s back.

So should I mark this tread as solved? Because it’s now obvious that this is a Chromium problem.


Did the latest Chromium updated rolled on Brave changed this behavior or it’s the same?

Do you mean this: 110.0.5481.100 chromium version from this update: Release Notes v1.48.164 (Feb 15, 2023)? No in this version it’s behaving the same way.

1 Like

@Vasekos that’s correct, on this case as was previously mentioned in this post the issue seems to be with Chromium rather than with Brave, I can only suggest you report this issue to Chromium support so they can be aware of it.

If you have any other concerns, please let me know or create a new post.

Regards :lion:

1 Like

Today I have updated Brave to Version 1.48.171 Chromium: 110.0.5481.177
And it’s fixed.
Anyway thank you everyone for your tips and time.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.