Aggressive Default Shield Settings and Signing Into YouTube

A few topics involving YouTube caught my interest and I use as aggressive shielding as I can. So this is another “I wish I didn’t have to do this but it is quick enough.” workaround.

Description of the issue: If you use “All” with Block Cookies on YouTube and try to sign in? It loops on the final part and gives a red bar error. For obvious reasons if you use maximalist aggressive settings, you can’t use YouTube at all.

How can this issue be reproduced?

  1. Keep individually disabling Block Scripts and move Block Fingerprints down to Standard to access YouTube
  2. Click sign in and then repeat until you can try to choose your account and then so you can put in the password.
  3. Continue and it will loop briefly before arriving at the red bar “There was an issue signing you into YouTube.” error.

Expected result: More built-in cookies or data that allow the last link Google tries to verify to go through so you don’t have to disable a shield setting at the Global defaults level.

Brave Version:
Version 1.62.130 Chromium: 120.0.6099.199 (Official Build) beta (64-bit)

Additional Information:
If you’re not a stickler about it like I am? Change Block Cookies to Only cross-site in the Global defaults ahead of going to YouTube and log in.
Outside of 2FA/Misc. there should be no more error.

If you want only the data you need?
Set to most aggressive shields and refollow the reproduced steps section until getting to the password input, then follow the bold. After you’ve made the switch you will still be able to log in with the currently active Google/YouTube sign in tab. Switch the Global cookie setting back to All when you’re on the YouTube homepage.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.