YouTube Login Failure

bug
#1

Description of the issue: I am able to log in any single of my services BUT YouTube. Everything works like a charm but YouTube is giving me back an error message every time I try to login.

I already tried to completely deactivate Brave Shields, to change the WebRTC (I have no idea if this is important for the login process, but I tried), to accept all cookies, all tracking… but all without success.

This is from a clean install of the new Chrome based browser. I downloaded it, installed it, setup my settings and tried to log in.

Steps to Reproduce (add as many as necessary):

  1. Could only be on my machine but one could try to copy the exact same settings as on my screenshots and hope that it reproduces the error.

Actual Result (gifs and screenshots are welcome!): Screenshots01, Screenshots02

Expected result: Being able to log into YouTube

Reproduces how often: 100%

Brave Version(about:brave): Version 0.55.18, Chromium: 70.0.3538.67 (Official Build) (64-bit)

Reproducible on current live release (yes/no): I hope so.

Additional Information: Original Reddit Post, Cross-posted Reddit Post

#2

Update: still the same issue on v0.56.12.

#3

@mcjvck,
In your Default Shields settings you need to change Block all Cookies to Block 3rd Party Cookies otherwise I don’t think YouTube is going to authenticate you. Let me know if this works.

#4

Having the same issue on v0.58.18.

I’m familiar with the need to block only 3rd party cookies when using a login across sites, such as google’s apps. It appears to be only YouTube that has this problem with Brave. It works fine with Firefox 64 with 3rd party cookies blocked, and it works fine with Brave for other google apps, such as gmail, calendar, and maps.

Clicking Sign In from Youtube’s main page takes me here: https://www.youtube.com/oops

I’ve tried signing out of google sites and starting the login from YT. Clicking Sign In from YT takes me to the normal google login, but after entering credentials, I get sent back to the Oops page.

#5

Sorry for the late response. Turns out I’m actually running into this as well. Let me dig around a bit and see if anyone knows whats going on. This definitely wasn’t happening on previous versions.

closed #6

This topic was automatically closed 60 days after the last reply. New replies are no longer allowed.