Can't sign-in to youtube

Description of the issue:

Steps to Reproduce (add as many as necessary):

  1. goto youtube.com
  2. click sign-in
  3. cookie problem detected by google

Actual Result (gifs and screenshots are welcome!):

We’ve detected a problem with your cookie settings.

Enable cookies

Make sure your cookies are enabled. To enable cookies, follow [these browser-specific instructions]

Clear cache and cookies

If you have cookies enabled but are still having trouble, [clear your browser’s cache and cookies].

Adjust your privacy settings

If clearing your cache and cookies doesn’t resolve the problem, try adjusting your browser’s privacy settings. If your settings are on high, manually add google to your list of allowed sites. [Learn more]

Expected result:

To sign-in to youtube and start watching videos.

Reproduces how often:

Every time I tried it today. When

Brave Version(about:brave):

Brave 0.63.55 Chromium: 74.0.3729.131 (Official Build) (64-bit)

Reproducible on current live release (yes/no):

yes

Additional Information:

When I first got Brave two days ago, it worked fine. I can still sign-in to google.hangouts no problem. I have followed every suggestion requested by google. Including cutting off Brave Shield. I can sign-in perfectly fine on other browsers.

@Dhaehar just want to make sure. Did you already tried to clear cache and cookies?

Yes, I have tried every suggestion.

I have the same problem. It arouse spontaneously on Brave, but not other browsers.

If you click on “Sign-In” does it redirect you too ‘accounts.google.com’ ? If not, what does it actually do?

Having the same problem. I was suddenly signed out for no reason, and trying to log back in just takes me to an error screen. Had no problems logging in on Chrome.

@OldG, @Dhaehar, @thapoint09
Welcome to new users.

I am allergic to signing in, anywhere. So I hardly ever sign in. I don’t think I have yet to sign in to many of my accounts using Brave. So I will be interested to see if I have the same problem when I get around to signing in to the Tube, etc on Brave.

If I want to sign in to accounts I use FF for that anyway - it keeps things like that separated. I have made up a quirky, little notion in my mind that this approach helps with privacy and security and that this procedure keeps Brave pristine. I am aware that this could be a total fallacy, but I like to humour myself in these matters. :rofl:
:leaves:

Having the same issue. YouTube takes me to the following link when I click Sign-In: https://www.youtube.com/oops

No message about cookies, and if I turn off the shields for YouTube the problem persists. One of the primary reasons I love Brave is the ad blocker for YouTube, so it would be great to understand how to fix this if anyone has any ideas.

@StevenMenking,
Did you import browsing data (cookies specifically) from Chrome when you installed Brave?

I’m pretty sure that I didn’t. YouTube was signing in just fine as of a few days ago. I didn’t change any settings around the time that the error message started popping up. Would any other information about my setup be helpful?

@StevenMenking,
Can you tell me how your Shields are configured for Youtube?
Additionally, can you try logging in while using a Private (or Private w/tor) browsing session and see if you’re able to login?

Here’s what my shields looked like:

image.png

I was actually just able to sign in fine just now without making any changes to my setup. When I got back to my computer I was signed out of all my Google accounts, and when I signed back in my YouTube was good to go. Rather strange! I typically use a VPN for reference. Thanks for your help!

VPN may have a part to play in this but it’s harder to tell without further testing. Additionally, you may want to check and ensure that you don’t have any data set to clear when exiting the browser.
Settings --> History --> Clear browsing data --> [On Exit]

1 Like

Makes sense, thanks again! It looks like everything is working properly, so it may have been on Google’s end.

1 Like

image

I think I found a resolution I had to enable Fingerprinting Proection from settings.

Unfortunately it doesnt seem like an option you have access to for each page like cookie controls

You can. https://support.brave.com/hc/en-us/articles/360023646212-How-do-I-configure-global-and-site-specific-Shields-settings-

Same thing’s happening to me, I contacted Youtube and they’re saying its a problem on Brave’s side. I’ve followed all the steps in this section to try and fix this issue and it just keeps going on with the oops window.

I am under the impression that Youtube and Google are doing this specifically as they called Brave “not an officially supported browser”

This seems fishy to me, but then again, youtube and google have been fishy for a while now.