After Migrating to New Brave from Old Brave browser Windows 10 still opening links in Old Brave

bug

#1

Description of the issue:
After migrating from Old Brave to New Brave browser Windows 10 still opening links in Old Brave.
There is only 1 Brave to be set as default in the settings (picture included below)

Steps to Reproduce (add as many as necessary): 1. 2. 3.

  1. Migrate from Old Brave to New Brave using the promt in Old Brave
  2. Set Brave as default browser
  3. Click on an external link or .html shortcut

Actual Result (gifs and screenshots are welcome!):
Windows 10 proceeds to open links in Old Brave.

Expected result:
I expect to open links in New Brave browser, not in Old Brave.

Reproduces how often:
Everytime I click on a link outside of Brave like in Thunderbird e-mail client or .html shortcut

Brave Version(about:brave):
Version 0.58.18 Chromium: 71.0.3578.98 (Official Build) (64-bit)

Reproducible on current live release (yes/no):
Yes

Additional Information:
I didn’t had Brave as default browser until I installed New Brave, then I switched and I set in Windows 10 settings. I tried to set a different browser by default then going into New Brave preferences and click set Brave as default browser which redirected me to the Windows 10 settings where I set Brave as default browser but it still open links in Old Brave by default.


I tried right clicking .html shortcut -> Open with -> Choose another app -> Look for another app on this PC -> selected brave.exe in
C:\Program Files (x86)\BraveSoftware\Brave-Browser\Application
Still opened in Old Brave. However if I open Brave using the same brave.exe then it opens New Brave.

Old Brave info:

Brave: 0.25.304
V8: 6.9.427.23
rev: 3ecf3237e16598a70e9063ba66513f617d97603f
Muon: 8.1.8
OS Release: 10.0.17134
Update Channel: Release
OS Architecture: x64
OS Platform: Microsoft Windows
Node.js: 7.9.0
Brave Sync: v1.4.2
libchromiumcontent: 69.0.3497.100


#2

We’ve had some issues with file type associations recently in Brave:

I would try to set the default browser to Edge or Opera or something else first, then try to switch to new Brave build.


#3

I tried it switching back and forth but didn’t worked. Tried it again now, still doesn’t work


#4

Then you’re encountering the issue that i listed above. It’s being reviewed by the team.


#5

Okay, thanks. Then I’ll wait for the fix.


#6