Ads Enabled But Not Earning BAT

Hello,

Thanks for taking the time to read my email.

I have ads enabled (5 per month) but I’m not seeing ads or earning BAT. I’ve tried uninstalling and reinstalling Brave, but that did not resolve the issue.

Please let me know if there are any steps I can take to troubleshoot or resolve the issue.

Kind regards,

Brad

@btjansen5 Please go through the post which will answer most of your questions FAQ: Why am I not seeing Brave Ads?

Thanks!

Thanks for your response.

The FAQ was helpful in understanding why I shouldn’t expect to see Brave ads on a consistent basis. However, my understanding is that Brave ads went live on April 24th. Is it possible to not earn any BAT for two months while using the browser 2 to 3 hours a day? What factors would contribute to Brave finding no relevant ads for a paticular user?

@btjansen5 Ads will be triggered based on the Ads categories available in the Catalog file. For example, If catalog containes 4 categories for your region (Personal Finance, Technology & Computing, Business and Education). If you browse any website, if it falls under any of these categories then ads will be triggered.
To check catalog category available in your region - https://ads-serve.brave.com/v1/catalog

2nd Question - “not earn any BAT for two months”

From the question what I understood is, you have been using brave for two months 2 to 3 hours pare day, you have not got any Ads Grants for the viewed Ads? I am not sure whether you are receiving ads notification or not, please confirm this.

Ads earning is not instant. once you view an Ad Estimated Earning will get increased by 0.0.5 BAT for each Ad view. Ads earning payout date is 5th of every month. Your earnings for the ads will be considered for next month.

Hope this will answer your questions.

Thanks!

Thanks for the information. I understand. I haven’t seen any ads yet, but I will give it some time.

I have a second unrelated question that I was hoping you could help me with. Lately I’ve been receiving Brave notifications in the upper right hand corner of my screen. They are from totally random websites that I never use. I don’t see an option to disable the notifications.

I went to Privacy and Security > Site Settings > Notifications. I have “Ask Before Sending” selected and I only allow notifications from one website (Protonmail). Yet I’m receiving a lot of notifications from websites that I don’t recognize. Do you have any suggestions? Thanks.

@btjansen5 Can you please share the Operating system details? would you mind sharing the screenshot of the notification you are receving?

Thanks!

Hello Geeta,

I thought that ADS were not available in Spain yet, but I see this interface instead of the “Not ads available for your region” Does that mean that Ads are now live in Spain or is this some kind of UI bug?

I have posted in this thread because I have not received any ad in that week, and I wonder what could this be.

Also, when I check on https://ads-serve.brave.com/v1/catalog I see a json with some BAT values and public keys, that means that there are ads for my region?

@gsabater Yes, your understanding is correct. Ads are NOT supported in Spain yet. If you are not seeing message “Sorry! Ads are not supported for your region” then it’s a bug.

Also, when you hit https://ads-serve.brave.com/v1/catalog in the URL bar, the catalog should not get downloaded it should be empty.

Would you mind sharing the catalog file?

Thanks!

yes, of course, should I paste it here or should I send you a PM?

Ive been using Brave Browser for a a few days now about 18 hours a day and have clicked on multiple adds and have yet to see a single BAT point !

And Yes ads is activated and yes im clicking on them and have even been taking the time to read them.

@gsabater Yes, please paste the catalog file content here.

Thanks!

@PolyDad Thanks for reaching out! Which country you live in? do you mean you are seeing Ads notifications but BAT is not accured in Ads panel for viewed ads?

Thanks!

The contents are the same if I access the endpoint with Chrome or with Brave.
In spain at 20-06-2019 without any VPN connected

{
"version": 1,
"issuers": [
{
"name": "confirmation",
"publicKey": "qi1Vl8YrPEZliN5wmBgLTuGkbk8K505QwlXLTZjUd34="
},
{
"name": "0BAT",
"publicKey": "uor3AzFj4OmdCxwetsYD1TxPXZSw40t3j/VOCUyC7Rs="
},
{
"name": "0.05BAT",
"publicKey": "mmXlFlskcF+LjQmJTPQUmoDMV8Co2r+0eNqSyzCywmk="
},
{
"name": "0.10BAT",
"publicKey": "IDHCAru7GPGQkmBvinkNYOu2HRotn6Zo4Mt92GjQeHc="
},
{
"name": "0.15BAT",
"publicKey": "duj8c6wshE1OsjpkQs2aP4GuFzg6AHRTx0bkdYUKaio="
},
{
"name": "0.20BAT",
"publicKey": "IJYNdVk9MIzc5vgn/4dQ5Xfb55kicxsNy4D4xAAtdX0="
},
{
"name": "0.25BAT",
"publicKey": "AkgrYZwV34g8kCp6PMzdpwe7jpHQVTQ9FvBmt77g5gw="
}
],
"ping": 7200000,
"campaigns": [],
"catalogId": "e6ae7ed749921a9a12b6a0e2b1c6ce4286f8fb0a"
}
1 Like

@gsabater Thanks for sharing the catalog file content. Catalog file is empty, it doesn’t show segments and Ads categories, which is expected as Ads are not supported for Spain.

You are not seeing Sorry! Ads are not supported you region message in Ads panel, because you must have set Locale as English (US) in your OS. Please confirm the same.

Ads should be served to user only when IP+Locale critera matches, In you case since region is Spain catalog is empty and ads are not available.

Hope this will answer your questions.

Thanks!

1 Like

I’m having the same problem with the same catalog and everything but I live in Puerto Rico and we’re in US territory idk if that still counts or those it have to be a state and not a
Commonwealth. btw. Love the browser

@Al3PRKILLER Thanks for reaching out! Ads are not yet supported for US territories, that’s why the empty catalog is downloaded for you. Issue is already logged, please track the issue here.

Thanks!

This topic was automatically closed after 30 days. New replies are no longer allowed.