Ads blocked even when Shield set to allow all trackers and ads

Description of the issue: Brave blocks ads on local news websites I visit even when I set Shield to allow all trackers and ads from the site.

Exact URL of the website in question: https://dailymaverick.co.za

How it looks:

How it should look:

Did the issue present with default Shields settings? (yes/no) yes

Does the site function as expected when Shields are turned off? yes

Is there a specific Shields configuration that causes the site to break? If so, tell us that configuration. (yes/no): no

Does the site work as expected when using Chrome? yes

Brave version (check About Brave): Version 1.23.75 Chromium: 90.0.4430.93 (Official Build) (64-bit)

@SIGSTART,
Thank you for reaching out.
Does it display the same if Shields are turned “off” entirely?
Additionally, if the above doesn’t work for you, you might try clearing cache/site data for just that site and then see if selecting Allow all trackers and ads works.

1 Like

Thanks for the quick reply.

Disabling Shields entirely fixes the issue.

This is not the only website this happens on.

Hang on. I was just about to type up an unexhaustive list of the local news websites I would like to enable ads for…

When I went back to the sites I was having trouble with and blocked trackers & ads, then unblocked trackers & ads it suddenly started behaving as expected.

Maybe there was just a blanket block on DoubleClick that somehow got fixed between yesterday and today?

1 Like

@SIGSTART,
Could be the case – I can check with our web compat. guys to confirm. Glad to know it’s at least working now though.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.